Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83

    Metal Clutch Washer Failed ??!!

    my friend own 04 RXP..his RPM dropped from 8100 to 6500 so as you all know its a sign of a washer failure..opend the supercharger and changed them to "Metal Washers" and also installed the "spring washers"...tried it today everything was ok but for 5 min and then again to 6500 !!!

    so what is the problem any ideas...did the metal washers fail ?!!


  2. #2
    How much damaga was cause when he blew the ceramics? Might have damaged something else. Did u reuse the needle bearings or did u buy a new one, they are hard to reuse, maybe u dropped one in the SC???

    Have u done the hybrid bearings yet???

  3. #3

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    Quote Originally Posted by 06viperrxp View Post
    How much damaga was cause when he blew the ceramics? Might have damaged something else. Did u reuse the needle bearings or did u buy a new one, they are hard to reuse, maybe u dropped one in the SC???

    Have u done the hybrid bearings yet???
    not that much no engine damage but some bits on the strainer found...i dnt know if he changed the needle bearing but my guess he reused them..and no the hybrid bearing wasnt installed...

  4. #4
    My mechanic took 1 look at the needle baerings and made me order a new one because he didnt even want to reuse the one thta was in there, he made a comment to me that if even 1 of the 40 needles fell and got into something it would be a disaster.

    I thought maybe some pieces got into the oil pump but I dont think this would happen that quickly to cause the pump to not work...............................Im sure someone will chime in soon to clarify things

  5. #5

    correct washers

    did u guys use the correct washers for the year boat you have

    if you use 04-05 washers in an 06 there will be massive slip

  6. #6

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    Quote Originally Posted by DIGGS View Post
    did u guys use the correct washers for the year boat you have

    if you use 04-05 washers in an 06 there will be massive slip
    yeah the we'v used the correct washers

  7. #7
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Quote Originally Posted by 06viperrxp View Post
    My mechanic took 1 look at the needle baerings and made me order a new one because he didnt even want to reuse the one thta was in there, he made a comment to me that if even 1 of the 40 needles fell and got into something it would be a disaster.

    I thought maybe some pieces got into the oil pump but I dont think this would happen that quickly to cause the pump to not work...............................Im sure someone will chime in soon to clarify things
    There is no reason why you can't reuse the needle bearings on a low hour sc. You rebuild the SC outside of the ski so I don't see how you could lose a needle bearing in a way that would cause a disaster since it would fall onto the work bench.

  8. #8

    Join Date
    Jul 2005
    Location
    Southampton, UK
    Posts
    190
    I guess all you can do is pull the SC and re-check. At lrast if it's slipping you can't harm yor engine!!

  9. #9
    Tennessee's Avatar
    Join Date
    Dec 2005
    Location
    Mt. Juliet, Tn
    Posts
    502
    +1
    2
    Might just be the s/c to TB hose didnt get tight enough and it blew off not letting it make any boost. With it going from 8100 right back to 6500 soo soon. The other thing that comes to mind is the gear had a crack from the first fail and when it slipped a couple times it gave and came off the shaft. hopefully it is not the problem. If it is he will be able to take the s/c intake hose off and spin the wheel.

  10. #10

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by Cdoo EtR View Post
    my friend own 04 RXP..his RPM dropped from 8100 to 6500 so as you all know its a sign of a washer failure..opend the supercharger and changed them to "Metal Washers" and also installed the "spring washers"...tried it today everything was ok but for 5 min and then again to 6500 !!!

    so what is the problem any ideas...did the metal washers fail ?!!
    are the ceramics from the first slippage still in the engine?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06-07 riva supercharger metal clutch washers for sale
    By H2HO in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 05-10-2009, 03:05 PM
  2. SC Metal Clutch Washers NEW!
    By Hydrogen in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-22-2007, 04:09 PM
  3. For those waiting on metal clutch washers and skegs
    By Green Hulk in forum 4-Tec Performance
    Replies: 13
    Last Post: 10-25-2006, 04:55 PM
  4. Installing Les Metal Clutch Washers
    By skipSC in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-03-2006, 01:19 PM
  5. metal clutch washers
    By Green Hulk in forum 4-Tec Performance
    Replies: 110
    Last Post: 04-07-2006, 01:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •