Results 1 to 3 of 3
  1. #1

    Angry 97 sl1050 no spark

    wanted to take my sl1050 out for a run today so i went out to
    start it up before going to the lake never happened
    checked for spark noticed a little spark occasionally at the end of
    cranking the wouldnt spark at all
    changed plugs with new ones same thing
    anyone got any ideas it ran fine a month ago

  2. #2

    Join Date
    Sep 2006
    make sure the battery is charged , what im thinking right after the starter quits it sparks , dont mess with the filled ones

  3. #3 rgard32's Avatar
    Join Date
    Dec 2006
    Saint Petersburg,Florida
    think there is some tech articles in the tech section on how to check the stator...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris sl1050 (engine sparks as soon as i let off start button only)
    By spannerspencer in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-10-2012, 06:54 AM
  2. 1997 SL1050 - No start, has spark/fuel/compression
    By mars22 in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 06-21-2011, 12:09 AM
  3. No Spark on 1997 SL1050
    By Syswatch in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-03-2009, 11:28 AM
  4. 1999 SL1050 NO SPARK! new PVL ign upgrade kit installed
    By john zigler in forum Polaris Open Discussion
    Replies: 4
    Last Post: 04-14-2009, 05:46 PM
  5. How-To: Spark Plugs
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 9
    Last Post: 01-23-2009, 05:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts