Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
  1. #11

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    874
    +1
    135
    Quote Originally Posted by Clickityclack View Post
    Looked at the diagram and couldn't find 92120, were you referring to another part number? Typo?
    92190. Sorry man, tired this morning.

  2. #12
    All good!

    No, I don't have that tube you mentioned, my ski is an 06 so it must have been eliminated by then. Good suggestion though!

  3. +1 by:


  4. #13
    Quote Originally Posted by sirbreaksalot View Post
    by doing what I suggested gives us a easy starting point...... if it still does it than we know to stay on the mechanical issue side of things..
    if it fixs it then we know SOMETHING is causing it to drive open.....

    or you can remove the air box and block the hole just before the throttle blade on the top of the body,

    the whole on the bottom is the idle bypass mechanical air screw..... 99% of people don't know how to correctly adjust idle speed/tps/rms on Kawi skies.

    Waz
    I took a look at the throttle body and can see the ports you’re referring to at the top that are controlled by the ISC. Are you suggesting I block them off and then rely on the set screw to maintain the idle speed? Also, wouldn’t I have essentially already done this by creating the blockoff gasket that goes between the ISC mounting plate and the throttle body? I think we know something’s holding the ISC open, but what’s doing it?

  5. #14
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,141
    +1
    595
    I am only suggesting to block them with your finger temporary for diagnosis purpose..
    Just to confirm if that circuit is the culprit .


Page 2 of 2 FirstFirst 1 2

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. High idle after stage 3 install
    By fly_kid006 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-20-2013, 12:56 PM
  2. rough idle after puting throttle body back together gp1300r
    By pnkrckchiro in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-05-2011, 07:54 PM
  3. XLT1200 has high idle after rebuilding
    By Steveard in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-29-2011, 05:53 PM
  4. High Idle After it runs a while
    By retro in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-14-2009, 06:37 PM
  5. High Idle After Flipping Ski and Taking on Some Salt Water
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 82
    Last Post: 07-12-2009, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •