Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
  1. #11
    Since u have the aftermarket IFB. When u get the battery back in try this. Listen to the IFB when u go from forward to reverse. Lanyard not inserted. Does IFB make a click sound. If so, its probably like mine and u need to leave it in reverse when not in use. Mine will complete discharge a battery (0 volts) in 3-4 weeks if not in reverse. Leave lanyard out also, or everything stays powered up.

  2. #12

    Join Date
    Aug 2013
    Location
    Nashville, TN
    Posts
    19
    K447,

    I remove the lanyard when not in use.

    Battery Tender Plus! and CTEK Multi US 3300. Is one better than the other?


    jetskier,

    I'll listen to IFB when I install a new battery. Thanks for the tip.
    Does your information center maintain the time, distance, etc. when you leave it in reverse?

  3. #13
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Clay View Post
    ...
    Battery Tender Plus! and CTEK Multi US 3300.
    Is one better than the other?
    ...
    Deltran certainly offers a lot of Battery Tender models.

    Is this the one you have?
    Battery Tender Plus 12V 1.25 Amp Battery Charger



    User Manual

    Quote Originally Posted by Deltran Battery Tender Plus documentation
    ... storage/float maintenance mode (... battery is 100% to 103% charged).
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	7473B26A-35E8-4836-AB13-6D774157356F.jpg 
Views:	16 
Size:	72.4 KB 
ID:	425083  

  4. #14
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Clay View Post


    MULTI US 3300 has a patented method for reconditioning sulfated batteries. The charger analyzes the state of the battery and, if possible, recovers the battery ...

    MULTI US 3300 is certified for use between -4F and +122F.
    Owners Manual

    Quote Originally Posted by charging modes
    ...

    Mode 14.4V/0.8A
    This mode is normally used for batteries <14Ah.

    Mode 14.4V/3.3A
    Normal setting for wet batteries, maintenance free and for most Gel batteries. Some gel batteries prefer a slightly lower voltage. Please consult the battery manufacturer when in doubt.

    Mode 14.7V/3.3A
    This setting is recommended for a battery at temperatures <41F. It is also recommended for many AGM batteries like Optima, Maxxima and Odysses. Consult your battery manufacturer when in doubt...
    I need to cross check this with the Deka ETX battery charging guidelines.

    Odyssey and a couple of other AGM brands have an unusual acid chemistry that requires a slightly different voltage than most other AGM batteries.

  5. #15
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Deka AGM battery recommended charge voltage range at various temperatures.

    http://www.dekabatteries.com/assets/base/0139.pdf



    Note the rather exact voltage ranges, specified to hundredths of a volt. Even a few tenths of a volt too much voltage or too little voltage matters, and can significantly shorten battery life.

    A chronically undercharged battery will degrade over time.

    An overcharged battery also suffers, especially if the charger is connected for long time periods with too high float voltage.

    Exercise for the student.
    Do either of those linked chargers deliver the correct bulk/absorption charging and float mode voltages for the Deka ETX type AGM battery?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	982FA25E-C686-4470-ABA7-BE04999AE585.jpg 
Views:	19 
Size:	110.6 KB 
ID:	425088  

  6. #16
    The console gauge doesn't loose any data. Only if u disconnect the battery. The aftermarket IFB is suppose to have reverse limiting, the 2 i bought said it did, never tested to see if it did. Putting it in reverse isn't turning off the battery. I think there is a relay or somethin in the IFB that is on when in forward and off when in reverse. Thats the click im hearing, it isn't very loud. Im wondering if that makes the reverse limitation work. Its not much pull on the battery, but 24 hours for 3 weeks the battery can't get a break. It finally gets low on voltage and fades away.

    I have a Schmauker 1.5amp with a pigtail, and a pigtail in the ski. It works good. Your batteries will last longer if maintained properly. The most i have seen it put out is 13.4-13.9 charging. Never looked at the voltage during charge complete cycle. This is a wet acid battery. I really think the battery was to small in the MSX's, it always sounds kind weak to me on cold starts, even with a good battery. Once warmed up it seems ok.

    Overcharging can destroy a battery, my boats onboard charger on bank 2 went crazy 4 months ago and was putting out 16-17 volts. I didn't know it. Heared a boiling sound a few weeks ago and the battery was really hot. Had to buy a new deep cycle and new charger. Battery only had 2 volts with the trolling motor loaded.


Page 2 of 2 FirstFirst 1 2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I have a 98 yamaha waverunner gp760 doesn't start just buzzes from the relay!
    By waverocket in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-19-2011, 01:50 PM
  2. Ultra 150 won't take off with the trim up?
    By 150ofUltra in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-07-2010, 04:51 PM
  3. MSX 150 Will not start on angle
    By rcsscraig in forum MSX/Matrix
    Replies: 11
    Last Post: 07-28-2009, 11:23 AM
  4. 99 Ultra 150 won't start
    By wareameye in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 09-24-2007, 06:48 AM
  5. MSX 150 won't start back up
    By Todd in forum Polaris Open Discussion
    Replies: 20
    Last Post: 04-28-2007, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •