Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
  1. #11
    Let me out of here......I need to go on Greenhulk!
    Join Date
    Jun 2008
    Posts
    376
    +1
    9
    OP says he had a 2011 300x that was blowing out the same hose. That is odd. Any worse depending on the time of year/water temp?

    Any way to post up a cooling diagram and point out which hose?


  2. #12
    What you're "spraying" on them may have an effect on the Hoses. My 2014 Ultra has 100 hours (completely stock) on it with the original stock hoses. I am one that believes you should spray nothing into the engine bay . . .

    When I am done riding the Ski, there is not one drop of water in the engine bay anywhere. Therefore, there is no need to spray anything into the engine bay. JB

  3. +1 by:


Page 2 of 2 FirstFirst 1 2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 SHO - why would main fuse keep blowing?
    By idealrides in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-03-2011, 07:49 PM
  2. GTX keeps blowing up, why?
    By Quad411 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-08-2008, 07:22 PM
  3. MFD keeps blowing fuses
    By brianstrange in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-30-2008, 02:12 PM
  4. 750 keeps blowing #3 piston. Pre Mix??
    By bobbeeler in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 12-01-2007, 07:18 PM
  5. dual trailers... what rims?? keep blowing out
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-01-2007, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •