Results 1 to 6 of 6
  1. #1
    skootz's Avatar
    Join Date
    Aug 2006
    Location
    Frankfort, ILL
    Posts
    2

    need help getting started

    Well I went to start my 98' GP1200 for the first time this season and enjoy it over the holiday weekend but it would not start. Checked the battery and it was fine, put in a different battery from another ski and it would not start. So we ruled out the battery....It did did make this squeaking/clicking sound from somewhere in the engine compartment though(I have never worked on a waverunner before so I don't know what the hell I'm even looking at). Also the battery terminals got really hot after repeated attempts to start it up. Does this sound like a starter issue or could it be something else? What else should I check or look for? I'd like to get it running asap


  2. #2
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    The first thing that you need to do is pull the plugs out of it and see if you can turn it over by hand at the rear coupler. This will let you know if it is a mechanical issue.

    If you can turn the engine by hand you will have to start tracing electrical issues.

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the forum !

  4. #4
    qbzonk's Avatar
    Join Date
    Aug 2006
    Location
    Orlando
    Posts
    975
    is the engine turning over?

  5. #5
    skootz's Avatar
    Join Date
    Aug 2006
    Location
    Frankfort, ILL
    Posts
    2
    Thank-you.
    It is not turning over. It only makes a faint clicking sound. And it ran fine prior to winterizing it so I don't know what the problem is???

  6. #6
    Check your ground. Then pull the plugs and try to turn it over with the starter if you dont want to do it by hand, pulling the plugs will release compression. Make sure you dont have anything it the pump tunnel that could be locking up the prop.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mustang GT guys - Need help getting started
    By mrbtd in forum Open Discussion
    Replies: 38
    Last Post: 07-07-2011, 08:21 AM
  2. need help getting ski going
    By PTLanza in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-02-2009, 07:57 PM
  3. Need help!! 785 start issues....what a surprise
    By goBENGALS in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-19-2009, 05:52 PM
  4. need help wont start
    By asia517 in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 08-31-2007, 08:14 AM
  5. XLT1200 I need help, wont start...
    By GeoRXT in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 07-29-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •