Results 1 to 4 of 4

Thread: Trim Problem

  1. #1

    Trim Problem

    Hi all I am new here but have a problem, Put new ride plate intake grate, milled the heads off 10thous. Ran good but trim stopped working. Is this normal for polaris and what usually goes out the motor odr what and do u know anyone selling one. Thanks guys. Hope u can help me and i can help you.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    HI 2500, WELCOME to the Green Hulk Forums!!

    Since I don't know the model and year I'd say measure for power to the wires leading to the motor. If you have power and ground to the trim motor the unit is bad. Some have talked about using an RC motor but I've always just used the motor out of a PRO so that it moves faster than the stock or older units.
    If you have no power/ground, let us know and we'll give you some more ideas.

  3. #3
    alright i have to do it with it running right. 96 sl780. and do u know anyone with a pro motor. Also i put a r& ride plate speed plate any good?

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    It does need to be running.
    Ride plates are in the eye of the beholder, if you like it, that's all that matters. I happen to LOVE the R&D intake grate but prefer the OP ride plate for my riding style.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki 900 zxi steering and trim problem
    By tom oswald in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 07-29-2009, 07:22 PM
  2. 96 xp trim problem, just getting a click
    By D-lish in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-24-2009, 10:04 PM
  3. 2004 or 5 RXP Trim problems
    By slambmx in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-20-2007, 04:24 PM
  4. 94 SL 750-Trim problem
    By nbpolaris in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-31-2007, 01:56 PM
  5. Trim Problems
    By nu2it in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-25-2007, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •