Results 1 to 9 of 9

Thread: MFD Says LoPr ?

  1. #1

    MFD Says LoPr ?

    I have just restored my MFD to somwhat working condition(1/4 amp fuse did the trick), It kept flashing "LoPr" and I figured it was because it was out of water and it could tell no water was running trough, anyway I was out riding last weekend and I have just rebuilt my top end so I was keeping a close eye on things. I went out and it ran great but the damn LoPr display that kept flashing got me worried, I thought it meant low pressure and was concerned about overheating the engine so I took it in to the beach, the engine seemed hot but not excessively but I took it home in fear that my cooling system wasnt functioning properly, after reading more I understand this LoPr message means low power, but the battery is brand new and well charged, the starter cranks very well and it runs perfect (although I did have a hard time getting started once, but I am running 25:1 right now to break in the new rings and pistons, so I figured it was fouling the plugs), does anyone have an idea hw t fix this erroneous message or should I not even bother with it, oh yeah it displays .2 volts when the volt mode is selected,..... whatever.


  2. #2
    You can try to reset the MFD by holding the SET button for ten seconds and while continuing to hold the SET button hold the MODE button for an additional ten seconds. Release both buttons and see if it works. On mine it did not so I bought the newer version of the MFD and all is well.

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You can also try disconnecting the MFD for a couple of hours.

  4. #4
    1996SLTX's Avatar
    Join Date
    May 2007
    Location
    Ft. Lauderdale, Florida
    Posts
    904
    +1
    1
    Anyone know a good source to buy an MFD? My works, but a lot of the crystals aren't working well and sometimes its hard to read the display.

  5. #5

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    Start the unit and check the voltage at the battery should be 13.5-14.3 volts dc at 3000 rpms if not suspect would be the voltage regulator. Ps check the grounds in the electrcal box.

  6. #6
    Quote Originally Posted by 4stroker View Post
    Start the unit and check the voltage at the battery should be 13.5-14.3 volts dc at 3000 rpms if not suspect would be the voltage regulator. Ps check the grounds in the electrcal box.

    Is there any way to fix the ghosting on the MFD's without replacing it? Where some of the characters are faded or always being displayed. It makes it difficult to read the left side of one of my MFD's.

    Thanks

  7. #7
    Quote Originally Posted by 4stroker View Post
    Start the unit and check the voltage at the battery should be 13.5-14.3 volts dc at 3000 rpms if not suspect would be the voltage regulator. Ps check the grounds in the electrcal box.
    im gonna put my money on this answer...this happened to my mfd one time and about 2 hours later the ski crapped out on me and we figured out it was a bad voltage regulator.

  8. #8
    I dont know, it is reading .2 volts so you might be right. There was corrosion on al the rivets holding the connectors to the main board in the CDI when I changed the fuse, I think the idiot who owned this ski before me sunk it and didnt clean it up right, anyway I will take it out Friday and run it all day and see if the battery dies. Where did you get the regulator and where in the CDI is it located, how much did that set you back, sorry for all the questions, but I am going to Lake Powell for 3 days next week and hope to get all the bugs worked out before I go exploring way out there.

  9. #9
    Lopr and 0.2 V is classic of a bad MFD. You can remove the MFD, unplug the connector and check the voltage I think on pins 1 & 2. If your reading is nominal battery voltage then you MFD needs to be reset or replaced.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mfd lopr
    By slxcrazy in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-26-2015, 09:55 PM
  2. What Did He Say?
    By Franko in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 10-12-2005, 04:42 PM
  3. Skippy says he finnaly got a ring.
    By Burnwater in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-03-2005, 11:52 AM
  4. New Limited Owner Says Hello...
    By FUELISH in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-30-2005, 10:30 AM
  5. new member saying hey
    By racerrob333 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-04-2005, 03:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •