Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28

    First problems with 2006 RXT w/65 hours

    Long time lurker, first time poster.

    1) I had a rock stuck in the impeller. Had a mechanic at the lake remove it with a crowbar. He told me based on visual inspection that I should probably replace the impeller (small chips around the edges) and housing or it may damage the sc/engine. However, after I rode it, the ski seemed fine - there was no noticeable loss of power. Any suggestions?

    2) After riding in the lake, I removed my seats to remove any excess water inside the hull and I noticed a loose spring about 4-5 inches long. Any idea where this spring got loosened from?

    Any response would be greatly appreciated.

    BTW, this is an awesome website.


  2. #2
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    I can only think of ONE place on an RXT that has a spring that large, and i think it may very well be the ONLY spring like that on any 4-tec Seadoo.... and i been thinking about this a few minutes in my mind before I posted tracing thru all the components picturing all the components of the RXT... and i can't figure out for the life of me how it could wind up INSIDE the hull.

    the OPAS rudder/fin on the side of the ski at the rear... those black paddle things... go play with them and on the 3-seaters (like ur RXT) push the entire fin UP... it has about 2 inches of movement... that's controlled by the spring and by water pressure... and that spring inside that housing is about 5 inches long give or take....

    other than that, i cannot for the life of me figure out where else there is a spring on a 4-tec... and how it got INSIDE the hull is beyond me.... so pretty much, there's no way it's from the OPAS system bc it can't get inside the hull from the outside.

    so either i'm overlooking something obvious, or someone dropped that in there along the line at the dealership or something.

  3. #3
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    On question number one, you definately need a new wear ring and I would suggest a new impeller too. Specially if it's really damaged. You might not notice it but you will once you put a new set in. You definatey need a new wear ring for sure.

    On question #2 I have no idea where that spring goes....

  4. #4

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    Thanks for the replies. Should I get a new impeller, wear ring and housing? (the mechanic suggested only the impeller and housing) I wanted to avoid taking it to the dealership for repairs based on the horror stories of some of the posters, but I guess I have no choice since I am not very good with the wrench.

    Any recommendations for a good sea doo mechanic in Los Angeles county?

  5. #5
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    I hardly think you need a housing, just a prop and wear ring would do. Since you're getting a prop, get the 14/17R and you will get better performance out of it.

  6. #6

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    What would the consequences be if I didn't get a new wear ring or impeller and just rode it in it's current condition?

  7. #7
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Decreased performance.

  8. #8

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    Besides decreased performance, would it harm the sc/engine or any other part of the ski?

  9. #9
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    I believe it its really damaged it can cause an inbalance (sp)

  10. #10

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    Thanks. I guess I better get the impeller changed.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has any one had any problems with the RXT IS
    By jumbojet in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-01-2010, 08:12 AM
  2. First Ride on 2006 RXT
    By MaxMike in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-30-2008, 07:14 AM
  3. Problem with 07 RXT
    By Seg in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-27-2008, 03:00 PM
  4. 74+ mph RXT after 65+ hours.
    By 01xdime in forum 4-Tec Performance
    Replies: 21
    Last Post: 08-07-2007, 09:14 PM
  5. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •