Results 1 to 6 of 6

Thread: need input

  1. #1
    tony4963's Avatar
    Join Date
    May 2007
    Location
    rhode island
    Posts
    35

    need input

    i have a 05 RXT removed exhaust silencer, filled ride plate holes, 3 in intake hose, 4 in fan in air intake hose pulling in air an a b kit looking to keep up with an 05 RXT w/stage 2 kitneed some help first time posting


  2. #2
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237

  3. #3
    Tennessee's Avatar
    Join Date
    Dec 2005
    Location
    Mt. Juliet, Tn
    Posts
    502
    +1
    2
    If that 4" fan is sealed in the intake hose you are killing yourself. There is no way an electric fan can feed 1% of the volume air you need so anything above idle you will be restricting yourself. Just pull the s/c hose off start it and feel the volume of air at idle comming out of the s/c and you will see.


    Quote Originally Posted by tony4963 View Post
    i have a 05 RXT removed exhaust silencer, filled ride plate holes, 3 in intake hose, 4 in fan in air intake hose pulling in air an a b kit looking to keep up with an 05 RXT w/stage 2 kitneed some help first time posting

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by tony4963 View Post
    i have a 05 RXT removed exhaust silencer, filled ride plate holes, 3 in intake hose, 4 in fan in air intake hose pulling in air an a b kit looking to keep up with an 05 RXT w/stage 2 kitneed some help first time posting
    Yep, tried the 4" atwood bilge blower in my intake. Worked okay but unbelievely not enough air @ 240 CFM. Took fan out of intake and connected at 90 degrees to the hull intake vent tube and blew the air on but not into my intake hose ss filter. Much better. Also did a few runs with the hood open about 4 inches...got another 150rpms. There is no doubt that a huge volumn of fresh air is needed to feed the hungry SC. The more you can get into the hull the better it will run.

  5. #5
    tony4963's Avatar
    Join Date
    May 2007
    Location
    rhode island
    Posts
    35
    thanks guys ..the fan just pushes air into the hull not sealed either took off the defucer from the stock box an put a 90 degree elbow there pushing air int o the hull an sc but just found out that my opas hose came off an i must have lost pump pressure only turning 7700 -7850 turned 8100 last yrs all the timeim going to keep reading an see were i get thank you very much

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    u have a b-kit? your metal SC clutch washers are probably slipping, that's where ur RPMs went probably. add shims to the clutch pack or get rid of those coated washers and get non-coated washers.

    also, get an external intercooler or an ECU (or both if ur finances permit)

    what speeds have u run with ur machine in the past?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Input
    By left coast girl in forum 4-Tec Performance
    Replies: 14
    Last Post: 11-20-2007, 06:40 PM
  2. Waterbox mod and still quiet - need input
    By c6rvette in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2007, 12:42 PM
  3. Need Input!!! PLease!! Seat On vs Off
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-19-2007, 08:58 PM
  4. Transom exhaust need input
    By Rodneyae in forum Polaris PWC Performance
    Replies: 15
    Last Post: 12-30-2006, 08:41 PM
  5. RXP Stage I parts shipped , need input!
    By Vern in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-24-2005, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •