Results 1 to 3 of 3
  1. #1

    Join Date
    Sep 2006
    Location
    Fort Laudedale Florida
    Posts
    59

    Polaris 1997 gauge showing E for error

    Polaris 780 1997 gauge showing E for error after battery misconection the fuse was bad and got replaced, gauge is showing E on the screen. How to reset it back to normal?


  2. #2

  3. #3

    Join Date
    Sep 2006
    Location
    Fort Laudedale Florida
    Posts
    59
    Quote Originally Posted by beerdart View Post

    Thanks that will help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ignition Update for Polaris 1997 SLTX 1050
    By LoveMySkis:) in forum Polaris PWC Performance
    Replies: 7
    Last Post: 05-21-2013, 10:26 AM
  2. WTB - Parts 2872403 - OEM Polaris Depth Finder Transducer Kit For MFI Display Gauge
    By ghostinstallations in forum Polaris Classifieds
    Replies: 0
    Last Post: 08-11-2012, 01:00 PM
  3. Yet another item to repair - gauge cluster needed for 99 GP1200
    By Byteme in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 05-25-2007, 09:46 AM
  4. stock 06 sea doo rxp RPM gauge shows 8360
    By XRIDER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-27-2007, 05:41 PM
  5. My boost gauge Installation: Lookin for opinions
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 07-22-2006, 11:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •