Results 1 to 3 of 3

Thread: sl 750

  1. #1

    sl 750

    Hi I have a 95 sl 750 that spins over then seems the motor locks up. If you wait maybe 30 seconds it will spin over again. If you remove the plugs they are very oily. I dont think it is the pump because with no plugs it spins fine. Almost seems like to much compression. The battery is new. Any help would be appreciated. Thanks

  2. #2
    polarispa's Avatar
    Join Date
    Aug 2006
    Cranberry PA
    How does it lock up? does it slow down then lock or does it suddenly lock?

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    air1 WELCOME to the Green Hulk Forums!!!

    I'd check for a fuel leak into the cylinders and see if you're hydro-locking due to a fuel leak. Needle/seat or something??

    Maybe try turning the fuel off and see what it does, it could be the dogone cases are full of fuel already.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SL650 750 Impeller Pump Assembly
    By beerdart in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-15-2006, 10:27 PM
  2. Just purchased a 1995 SLT 750.. Questions
    By daveo13 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-08-2006, 03:59 PM
  3. Is this a good deal? $750 for a alum. trailer
    By addicted in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-05-2006, 07:17 PM
  4. My 750 project continued
    By ph2ocraft in forum Polaris PWC Performance
    Replies: 4
    Last Post: 08-31-2006, 06:23 PM
  5. Al's New SL 750 Dash Panel
    By CrazyA in forum Polaris PWC Performance
    Replies: 17
    Last Post: 08-31-2006, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts