Results 1 to 6 of 6
  1. #1

    Thumbs down Rxt 06 stage 3 cutting out after warming up

    Hi guys cab anybody help with this problem

    I have a stage 3 rxt rude charger 50 lb injectors riva intercooler pre filter catch can 15 19 3 blade skat custom trim 81 mm trim ring

    It pulls hard 77.8 on gps at 8550- 8600 then once warmed up i have a huge lag when i hit the gas then works thru the lag and only pulls 8250 -8400 and 74.8.

    I have talked to everyone at riva no help there

    Please Help


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Check your overflow bottle and see if it's full. I've heard of massive blowby with some of the higher boosted engines.

  3. #3
    thanks mark

    Checked the blow bottle has a little in but not a lot.

    anything else come to mind

  4. #4
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    t pulls hard 77.8 on gps at 8550- 8600 then once warmed up i have a huge lag when i hit the gas then works thru the lag and only pulls 8250 -8400 and 74.8.
    So is this the part when you say "cutting out?"

  5. #5
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Welcome to the forum TIBFIB!

    You are in the right place, listen to what they have to say.

  6. #6
    Quote Originally Posted by Hydrotoys View Post
    So is this the part when you say "cutting out?"
    this is when the lag accurs then sputters and then clears

    thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 06-14-2015, 05:10 PM
  2. NPV 1200 Cutting Out after 1/2 Run Time
    By SUV1200 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 02-08-2014, 04:49 PM
  3. Help - 2013 RXT-X Sputtering/ Engine cutting out.
    By AC2000 in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-03-2013, 11:39 PM
  4. Just cuts out! After hull swap. Please any help is good!
    By mongaupt in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-17-2010, 10:42 AM
  5. 1994 Polaris SLT 750 Engine cutting out after repairs
    By kxs in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-03-2009, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •