Results 1 to 4 of 4
  1. #1

    Throttle sensor 2004 MSX 110

    I have gone thru 2 of them in less than a year. Anybody else having problems with them? Mech. always asks if I have been towing with it and we never have.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    man, don't get Bernie started he HATES those suckers.
    I'd say they are the weak link to the MSX140. Is your tech adjusting them to see close to 100%

  3. #3

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    bud they have gone thru 5 different tps sensors last few years,new one seem better(one you got may have been old stock

    later cd

    towing ?wtf has nothing with that??

  4. #4
    That's what I thought about towing

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 msx 110
    By fusion900 in forum MSX/Matrix
    Replies: 7
    Last Post: 11-11-2012, 11:06 AM
  2. No Throttle on 2004 MSX 110- Help!
    By JetSki6 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-01-2008, 08:38 AM
  3. 2004 Msx 110
    By fusion900 in forum MSX/Matrix
    Replies: 9
    Last Post: 04-23-2008, 08:06 AM
  4. 2004 MSX 110 revving up when starting?? Help!
    By viperbusa in forum MSX/Matrix
    Replies: 4
    Last Post: 02-08-2008, 09:18 AM
  5. 2004 msx 110
    By posfit in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-26-2007, 06:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •