Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Beagleman62's Avatar
    Join Date
    Mar 2007
    Location
    Richmond, Virginia
    Posts
    2,726
    +1
    64

    No oil in intercooler

    When I pulled the intercooler to install some exhaust mods, my intercooler was clean as a whistle. I had ckecked out the intake hose a couple of months ago (after I dicoverd that my 250 was also overfilled with oil) and found almost no evidence of oil although I did see a trace in the BOV. My ski was overfilled by at least 1 quart. A lot of people have had to clean their intercooler because of overfilled oil but I guess I got lucky. It's kinda wierd because I rode my ski about 3-4 hrs before I found out about the oil problem people were having.


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    When you get the oil level right, the oil thats in there eventually gets blown through the system.

  3. #3
    need4speed's Avatar
    Join Date
    Apr 2007
    Location
    Austin
    Posts
    59

    Unhappy Oil in Mine

    Looked at mine today and I had oil in mine. Wish I hadn't. The rubber gasket does not fit back and now I have to order another one.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	cooler.JPG 
Views:	87 
Size:	414.1 KB 
ID:	29829  

  4. #4
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Quote Originally Posted by need4speed View Post
    Looked at mine today and I had oil in mine. Wish I hadn't. The rubber gasket does not fit back and now I have to order another one.
    Holy moly....Is that adhesive in the pic or coagulated oil? Thats like 30-40% blockage. Mide did not have oil in it and definately does not look like that.

    Try permatex "high tack" or Gaskacinch to spot pin the rubber cord. Ordering a new one is good too, but might have same issue.

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Anyone have pics of their intercooler installed in their ski and hooked up?

  6. #6
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Quote Originally Posted by JFizzleJR View Post
    Anyone have pics of their intercooler installed in their ski and hooked up?
    There ya go
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00608.JPG 
Views:	70 
Size:	146.6 KB 
ID:	29838  

  7. #7
    rhorne1053's Avatar
    Join Date
    Oct 2006
    Location
    Santee, S.C.
    Posts
    634
    That almost looks like oil and water mixed.

  8. #8
    need4speed's Avatar
    Join Date
    Apr 2007
    Location
    Austin
    Posts
    59
    That was the oil clogging the system up. Mine was over filled by the dealer. Needless to say; I am doing my own oil changes. I was suspect that this issue was going to be the case since that little tube in the front of the engine keeps getting oil in it. What I don’t understand is why the gasket is doesn’t fit anymore.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	cooler_before.JPG 
Views:	48 
Size:	1.57 MB 
ID:	29903   Click image for larger version. 

Name:	cooler_after.JPG 
Views:	56 
Size:	1.99 MB 
ID:	29904  

  9. #9
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    you can get a whole set of gaskets for like 15 bucks from a dealer.

  10. #10
    rhorne1053's Avatar
    Join Date
    Oct 2006
    Location
    Santee, S.C.
    Posts
    634
    How many hours did you have on yours to get that kind of oil in the intercooler? It still looks like oil is mixing with water by the color that I am seeing.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil in intercooler
    By rolo2230 in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 01-23-2013, 09:16 PM
  2. MSX-140 No Oil in any of the oil lines
    By JohnCiccarelli in forum Polaris Open Discussion
    Replies: 11
    Last Post: 01-04-2013, 09:19 AM
  3. Oil in intercooler?
    By brisyl in forum Kawasaki PWC Performance (4-stroke)
    Replies: 19
    Last Post: 03-19-2010, 08:39 AM
  4. oil in intercooler... problem?
    By braaapf7 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-13-2009, 05:22 PM
  5. milky water/oil in intercooler
    By shhr in forum 4-Tec Performance
    Replies: 34
    Last Post: 09-07-2006, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •