Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24

Thread: Starter Click

  1. #1

    Starter Click

    Installed a new battery in my 94 750 SLT and push the start button to only hear click. Ran well all last year until she was stored. Could the engine be seized or is the starter just bad? help please


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hi BRAD, WELCOME to the Green Hulk Forums!!!

    You can remove the cover over the drive shaft and then see if you can rotate the engine by hand.
    Did you charge the battery as per the directions or just install it?
    Are the connectors clean at the battery?

  3. #3

    Starter Click

    I installed the battery after filling it with the acid. The next day I installed it to get just the click so I put a slow charger on it for about 8 hours when it was installed and still got just the click. the charger amps jump up to 6-8 right after I hit the statr button and stays there until it slowly goes down to fully charged. needle all the way to the left

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Make sure you can rotate the engine just so you know the engines O.K.

  5. #5
    Is it OK to charge the battery like that? Also can you jump a PWC off of a car if needed? If I can turn the engine could it be the starter? I will try to turn the engine in the am, Thanks for your help

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Remove the sparkplugs first, before you try turning the motor by hand. It makes it ALOT easier. If the engine turns, that's good. It may be a starter, or a bendix, or poor connections like PH20 said. Definately leave the battery on the charger overnight, just to make sure it is fully charged.

  7. #7

    Starter Click

    Well good news I can turn the crank byhand so she is not locked up. I left the charger on all night on the new battery and still only get a click at the starter when the button is pushed. I even jumped it off of a car battery still just clickclick. Any suggestions, If I need to take the starter out how hard is that? it looks like the starter is down under the exhaust manifold. Also I noticed a brown wire from the electrical box that was broken off of a piece that bolts under the exhaust manifold can that affect the starter?
    Last edited by Brad; 06-03-2007 at 08:06 PM.

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    That is good news, the rest is easy.
    First clean that ground cable that attaches to the engine or engine bed plate, it's famous for a poor connection.
    If that doesn't work, try by-passing the starter solenoid.
    If that doesn't work, try a secondary power source, put the + directly to the large starter wiring leading to the starter and the - directly to the engine and see if it turns over.
    If none of those work, remove the starter and test outside.

  9. #9
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    Ah I feel your pain, I have to try all these tricks again. It's usually just a bad ground somewhere.

  10. #10

    Starter Click

    Thanks for all your help, Where do I find the main ground? Does it go from the battery to the engine? How do you bypass the solenoid? Does that brown wire do anything important? If I need to get the starter out how do I get to it? Thanks

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zxi 1100 wont start, just clicks, tested starter motor good.
    By boostintt in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 06-06-2012, 06:20 PM
  2. Starter soleniod just clicking on 650sx
    By BADSL900 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 02-13-2012, 11:33 AM
  3. 97 SPX Solenoid clicks but starter does not run
    By ARBEE in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-04-2011, 10:54 AM
  4. Ultra 150 starter/clicking sound and need a manual
    By masonsied in forum Kawasaki Open Discussion
    Replies: 24
    Last Post: 10-01-2008, 09:15 PM
  5. The dreaded starter *click*
    By mystahagy in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-08-2007, 09:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •