Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: 250x Cavitation

  1. #1
    jimhart's Avatar
    Join Date
    Feb 2007
    Location
    Twin Cites
    Posts
    25

    250x Cavitation

    On hole shots my 250x cavitate from 3 to about 10 mph, is there anything you can do to fix this?


  2. #2
    blownhotrodder's Avatar
    Join Date
    May 2007
    Location
    Buford, Ga.
    Posts
    601
    Yea get the pump stuffer kit. Its called the pump shoe seal kit from r rated or one of the others. I think its around $68.

  3. #3
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,445
    +1
    650
    Also check the pump seal , and look into the gullet and makes sure there is no silicone hanging down in there.

  4. #4

    Join Date
    May 2007
    Location
    Highland Village, TX
    Posts
    9

    No more cavatation!

    My cavatation problem was repaired. Thanks to the more mechanically inclined group on this website... I printed the thread from the forum and took it in to the dealer. The first time they thought it was the belt slipping. After I took them the info, they cleand out excess silicone in some areas and added where it was missing in others. Now, no cavatation... excellent accleration. Kawi is now aware of the problem and it should be easily fixed by any dealer under warranty. Now to work on top end speed... speedo shows 56... GPS says 63.

  5. #5
    Been around for years...seen it all Kawi-Guy's Avatar
    Join Date
    Oct 2006
    Location
    Naples Florida
    Posts
    828
    +1
    27
    Bruss,
    please loosen your speedometer paddle assembly in the rear of your ski and move it downward. Then re-tighten it.
    This will fix your speedo problem

  6. #6

    Cavitation

    First hour bad cavitation,dealer found washer on jet pump seal .Hadn't tried it yet.We'll SEE

  7. #7

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451

    Exclamation

    Quote Originally Posted by Buzzair View Post
    First hour bad cavitation,dealer found washer on jet pump seal .Hadn't tried it yet.We'll SEE
    Rant ON:
    $50 bucks say`s there are blowing smoke..... .
    $50 say`s they didn`t do jack.
    Another $50 say`s it`s still gonna have cavitation.
    And yet another 50 bucks say`s your dealer is a Big A_ _ Hole.
    Rant OFF:
    Sorry. I hope they fixed it.... F/N dealers are usless.

  8. #8

    Join Date
    May 2007
    Location
    Highland Village, TX
    Posts
    9
    Quote Originally Posted by Kawi-Guy View Post
    Bruss,
    please loosen your speedometer paddle assembly in the rear of your ski and move it downward. Then re-tighten it.
    This will fix your speedo problem
    Kawi-Guy,

    Thanks for the input... I'll give it a try.

  9. #9

    Join Date
    May 2007
    Location
    Highland Village, TX
    Posts
    9
    Quote Originally Posted by Kawi-Guy View Post
    Bruss,
    please loosen your speedometer paddle assembly in the rear of your ski and move it downward. Then re-tighten it.
    This will fix your speedo problem
    Kawi-Guy<

    I tried to loosen the speedo assemly and move it down as suggested. I loosened both nuts (allen wrench) but the assembly would not easily move down. I did not want to force it. Am I missing something?

    BRuss

  10. #10
    rhorne1053's Avatar
    Join Date
    Oct 2006
    Location
    Santee, S.C.
    Posts
    634
    Quote Originally Posted by BRuss View Post
    Kawi-Guy<

    I tried to loosen the speedo assemly and move it down as suggested. I loosened both nuts (allen wrench) but the assembly would not easily move down. I did not want to force it. Am I missing something?

    BRuss

    Something else you guys might want to try. I rode last weekend and noticed that my speedometer was reading a lot slower than it had been before. Today I got to looking at the speed wheel on the rear and when I thumped it, it would only turn a couple of times. I sprayed some wd40 on it to loosen it up. Well guess what it reads more accurate now than it ever has, for some reason it was not free wheeling.

    This may have just been mine but it sure is a quick way to check.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 250x cavitating out of the hole
    By cvbdrew in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-01-2013, 05:21 PM
  2. Ultra 250X R&D Anti-Cavitation Cone
    By ghashimoto in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 03-02-2012, 06:23 PM
  3. Prop boot and cavitation
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-28-2011, 08:09 PM
  4. Cavitation issue: worried
    By BDNJ in forum 4-Tec Performance
    Replies: 62
    Last Post: 09-13-2005, 08:21 AM
  5. Post on cavitation
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-04-2005, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •