Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    not happy with the work done to my pump

    i had a realy crap weekend i went and put the pump back to geather and its still doing the same thing as what it was doing before i got it fixed and for those that dont no what it was doing the sleeve in the housing stuffed up and the prop was hitting it so i sent it away to get the prop shaved and a new sleeve put in the hosing and i put it all back togeather and the prop will spin a bit and than it will jam up with the sleeve still so im not happy dose anyone no why it will still be doing this

    i just rang the guys that did the work to the pump for me and the dude said to start the ski with out the pump in it get it worm than to bolt the pump up and leave the bolts abit lose and same with the bolts that hold the pump to the ski start the ski with flush kit on and a hose running into the pump to than do bolts up holding pump to ski than do bolts on pump its self and he said it shold be right than

    is this going to work ???????????????????????


  2. #2
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    i never heard of that. i dont think i would try it

  3. #3
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Welcome Ando.

    What kind of ski.
    What year pump.
    Who did the work.

  4. #4
    Nickeljet's Avatar
    Join Date
    Feb 2007
    Location
    Moss Bluff Louisiana
    Posts
    301
    +1
    2
    Is this a SSwear ring or a plastic one?

  5. #5
    If it was a palstic liner and out of the box prop you should have left the prop alone and sanded the liner a bit assembled it, spray wd40 and allowed the prop to cut the rest of the plastic liner for a tight fit.

    Who gave you that advise????
    Last edited by Fercho; 06-04-2007 at 11:03 PM.

  6. #6
    If Im reading this correctly, your saying to tighten the bolts while the sharp repitched prop is spinning 1600 rpms? MORE BAD ADVISE!

    Dont even tell me that RIVA gave you this advise also.

    Just out of curiosity, If this is your first post on this forum how would anybody know about your pump problem? Did you have a different name before?

    Welcome to the forum.

  7. #7

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    make sure the Dowl pins are in both side of the wear ring (there should be two on ether side) If it is ok check and see if the bearing on the inter shaft is good.
    Mike

  8. #8
    Quote Originally Posted by porksword View Post
    If Im reading this correctly, your saying to tighten the bolts while the sharp repitched prop is spinning 1600 rpms? MORE BAD ADVISE!

    Dont even tell me that RIVA gave you this advise also.

    Just out of curiosity, If this is your first post on this forum how would anybody know about your pump problem? Did you have a different name before?

    Welcome to the forum.

    im from the land down under and i got this post in a thread here in oz

  9. #9
    my ski is 97 98 waveblaster 2 i got a steal sleeve put back in to the housing and the prop shaved down

    the guy ive been taking to said thats what they do and than they put the skis in the test tank and leave tham running for about 20 mins so if i do the same thing with my trailer by putting it in the water with the ski still on and having the water up to the pump and leave it running it should do the same thing
    Last edited by ando85; 06-04-2007 at 07:50 PM.

  10. #10
    It almost sounds like they didnt match the prop and the sleeve properly so they would rather you wear it down by running it than just making it right for you. If it was a plastic liner it would be ok for the prop to cut it to shape but I wouldnt do it with a steel liner.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Not happy with my new R&D intake grate
    By WickedXP in forum 4-Tec Performance
    Replies: 59
    Last Post: 08-05-2014, 07:57 AM
  2. Traveling with the ski...how to secure it?
    By Fatty in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 06-11-2009, 08:23 PM
  3. Replies: 5
    Last Post: 03-22-2009, 08:53 PM
  4. 1200 Gpr Waveeater Clips With The Works Needed
    By noshowallgo in forum Yamaha Classifieds
    Replies: 0
    Last Post: 08-30-2008, 09:36 AM
  5. What I have done to my 250.(70.7 mph)
    By Aquaholic6801 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 135
    Last Post: 01-26-2008, 05:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •