Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41
  1. #1
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77

    RXP RPM Limiting Question

    Are you aware of any ways in which the RXP will limit its allowable RPM without showing an error code? For example, I hear some people say if you overfill the oil, the ski won't go over 7600 RPM. Is this true and are there others?


  2. #2
    Senior Member watermedic's Avatar
    Join Date
    Apr 2005
    Location
    West Virginia
    Posts
    383
    Yes the oil overfill cutting RPM's is true. A wear ring in the first stages of "getting tired" will cut RPM's also. I have had this happen as well as Hulk.

  3. #3
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,812
    I have a friend who's RXP stops at 7600! He only has about 40 hours on it and we have already taken out the "overfilled" oil that the braniacs from the service department put in. What is this wear ring Hulk is talking about? Could the fact that they used synthetic have anything to do with this. We are changing his oil tomorrow.

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,885
    They used synthetics? Geez, some of these dealers amaze me!

    Check out the wear ring in the pump. Could be that it is worn and causing low RPM's. Several others and myself have found that if the wear ring is worn you will lose RPM's.

  5. #5
    jk's Avatar
    Join Date
    May 2005
    Location
    Pt. Charlotte, FL
    Posts
    136

    RXP NO SPEED OR RPM EVEN W/MODS

    Serious problems ever since first service in which knock sensor update was done. Approx. three hours later supercharger let loose. Then entire motor had to be rebuilt. Got it back boat won't go over 7650 RPM. Now stage 1 RR kit and stage 1 PPG, Riva intake grate and 2 degree wedge and a custom 4 inch air intake, Rotax Racing Waterbox and boat still only runs 7650 to 7700 RPM at 68 miles per hour. Talked to Glen at PPG, he reccomends reinstalling original ECU and doing knock sensor update again. That's where I am this morning and will test later today. Anyone with any insight or suggestions please help.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,885
    jk,
    it sounds to me like the piggy back harness for the knock sensor update was left in the ski.

    The 2004 models had a knock sensor update. 1/2 the update was in the ECU and the other 1/2 was the installation of a small wire harness about 10 inches long that plugged in between the knock sensor and the existing harness. Ensure that this piggy back harness has been removed.

    This link will help you
    http://www.greenhulk.net/forum/viewtopic.php?t=245

  7. #7
    jk's Avatar
    Join Date
    May 2005
    Location
    Pt. Charlotte, FL
    Posts
    136
    Thanks Hulk, but I've checked that and it for sure isn't there. That's why Glen suggested reinstalling original ECU and the piggyback harness, running the boat 0-wide open to reset the GPS sensor. I've found out that when the motor was rebuilt they never reinstalled the piggyback harness at all & something probably didn't reset correctly. On my way to dealer/service rep. now to test this theory.

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,885
    cool! let us know how it turns out.

  9. #9
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    I'm hearing this 7600 number more and more. Wonder what's happening out there.

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,885
    unrelated issues Jarrett i'm sure.
    I think Franko will find his problem in the pump this afternoon

    Did you get your ski back together and ready to run?

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP rev limiter question?
    By skigolfnut in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-23-2012, 08:19 PM
  2. Replies: 6
    Last Post: 11-26-2010, 01:09 PM
  3. bone stock rxp, rpm and speed question?
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2007, 09:27 AM
  4. 07 Rxp RPM Question ?
    By orange71rt in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-13-2007, 07:44 AM
  5. Question on 06 rxp rpm's???
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-17-2007, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •