Results 1 to 6 of 6
  1. #1
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063

    re-installation of the pump

    when re-installing my pump, do i need to use silcone sealant or anything or do i just blue locktite it up and call it a day? thanks


  2. #2
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    i put lots of anti sieze/marine greese on the splines and make sure the black gasket is still good then just bolt it on snug, no loc tite for me.....

  3. #3
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063
    is the brp synthetic grease that i will be packing into the pump cone suffecient to put on the splines?

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    clean the neoprene seal and pump shoe with windex and install that dry.

  5. #5
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063
    sounds good steve

  6. #6
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    i am sure that will do, anything to keep salt water out..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 02-23-2010, 07:25 PM
  2. Were there any solid results regarding the installation of the SHO nozzle?
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 06-26-2008, 10:04 AM
  3. 2008 Re-Release Of The Camaro!! Beautiful Pics
    By ABBOTT in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 08-12-2006, 11:15 AM
  4. 2008 Re-Release Of The Camaro!! Beautiful Car
    By ABBOTT in forum Other Toys
    Replies: 0
    Last Post: 08-06-2006, 10:09 PM
  5. Pics of Installation of Bilge Pump
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-14-2005, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •