Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Va Beach, VA
    Posts
    1,425
    +1
    28

    WTF ?? My pump housing is warped and cracked ....

    Ok so I completely stripped down the 00 genesis I bought for parts / to part out. I found out why the pump/motor would not spin. I was thinking it was a bearing, but what I found instead is something I have never seen or heard of. The pump housing around the impeller is cracked in half, and the metal sleve is wavy. Basically it was like it expanded, cracked the housing, then shrunk around the impeller. I took some pics, lets see if I can post em...

    So my question is, how, and why ??

    Guess I won't be selling that pump assy !!
    But I will be keeping the stator, I think its a good upgrade for the SLT. I should be able to replace the bearings in there right ?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CIMG1733.JPG 
Views:	47 
Size:	81.7 KB 
ID:	26905   Click image for larger version. 

Name:	CIMG1734.JPG 
Views:	51 
Size:	83.0 KB 
ID:	26906   Click image for larger version. 

Name:	CIMG1735.JPG 
Views:	52 
Size:	83.2 KB 
ID:	26907   Click image for larger version. 

Name:	CIMG1737.JPG 
Views:	56 
Size:	82.9 KB 
ID:	26908  
    Last edited by UnityRacing; 06-04-2007 at 07:50 PM.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    That is extreme I have seen a few that have started to warp but nothing like that. It is due to galvanic corrosion. Is the anode in place. my guess is it's gone. The soft aluminum acts like a battery and slowly erodes.

  3. #3
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Va Beach, VA
    Posts
    1,425
    +1
    28
    The ski sat for quite a while in the water, then for 2 yrs out of the water. The redneck (sorry if I offended anyone lol) I bought it from didn't know the first thing about this ski.
    Anyway, do you have a picture of this anode ?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    In the lower right pic there is a bolt that is where the anode would be it is a Zinc disc the bolts to the wear ring and is slowly dissolves before the aluminum.

  5. #5
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,141
    +1
    1,050
    Its the piece that would have been here....


    .
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CIMG1735.JPG 
Views:	55 
Size:	95.5 KB 
ID:	26913  

  6. #6
    I'd run it! getr done! lol The Redneck way!

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    .
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CIMG2212.JPG 
Views:	58 
Size:	970.3 KB 
ID:	26920  

  8. #8
    My boat,trailer,ski's and truck love our fresh water!

  9. #9
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Va Beach, VA
    Posts
    1,425
    +1
    28
    Hmm, the arrow crazya is pointing to is I think something else. I did see a small bolt that was screwed into the housing and I couldnt figure out why it was there. I guess the damn thing dissovled a long time ago !!

    So that wavy part is called the wear ring ?

    Also the impeller is stainless, still in good shape if cleaned up, but on one of the blades the very very end has a small bend in it. I don't think this will keep it from being useable, however do these need to be balanced or anything, maybe it *needs* to be repaired ?
    Would this factory impeller be a good upgrade for a different hull ?

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Get the numbers off of it and we'll see what it fits.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Did my Impeller "Swell" or did my Pump Housing "Shrink" ??
    By indngvr in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-12-2011, 06:52 AM
  2. Is Wear ring and Jet Pump Housing the Same?
    By martinworth in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-14-2009, 03:37 PM
  3. part numbers for bearings and seal in the pump housing
    By gvnitup in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 05-03-2007, 08:25 AM
  4. Ok - My pump is going to Skat
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 04-13-2006, 01:30 PM
  5. thinking of Selling my RXP. Wife is pregnant and due March
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-07-2005, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •