Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    99 SLTH running lousy

    Hi everybody, hope I can get some help here. Got a bit of a problem with this, runs decent hit a good wake and it starts to run lousy, hit another wake and it seems to start running fine again. I've checked all connections and they seem clean and tight battery is new and holds good charge I'm thinking fuel but not sure where to start. Thank's for any help


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Are you sure there are no loose connections in the electrical box? Are there any warnings on the mdf?

    And by the way, Welcome to the Green Hulk Forums!

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hammy, that's a toughy!!
    I had one with almost the same problem eons ago.
    I wound up installing a spark tester and running the boat near night fall, it wound up the spark would get erratic on one large wave and clean up on the next two or three. Wound up being a loose pick-up at the stator.

    I've also seen them where the older type NGK plug will actually fail, the center electrode would bounce out of place, next hit and it dropped back into the correct location.

    Could also be a needle/seat assembly staying open or binding creating a flood condition.
    If you haven't touched the carbs it probably wouldn't be a bad idea for a rebuild and needle/seat replacement. It will need it due to age anyway......
    Just some thoughts.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Oh and how rude of me.

    WELCOME to the Green Hulk Forums!!!

  5. #5
    Thank's for all the input! I will go through them all, starting with the carb seats. I went through the E-box and everything was clean and tight. the stator was replaced last season so I will be checking out the pickups as well. Thank's again I will let you know how it goes.

  6. #6
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Exaust leaks maybe ? .Lift the seat after it does it and see if it runs better

    Bernie

  7. #7
    found a plugged vent under the seat and missing a gasket that goes between the carb and the airbox. Hoping that is it, haven't had much ride time but will be checking the spark theory and replace the plugs. will update. Thank's

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I'm dyeing to read what solves your problem.

  9. #9
    Hi again, talked to a guy who is a polaris technician and he says to check the oil pump cables. He says that if they are out of adjustment they cause a sensor to bog the motor , I don't remember any sensors or wire that was attached to the pump. I will be going to check it out later this week.

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Doesn't sound right.
    Have you by any chance checked the carb filters?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. running problems on a 99 slth
    By kastay29 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-27-2011, 09:03 PM
  2. 99 SLTH - Top End Runs great, bogs down at low RPM
    By thiagoavila in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2010, 12:02 PM
  3. '99 slth running hot - hellp needed.. =)
    By fr33man in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 06-16-2008, 11:51 AM
  4. 99 GTI running poorly
    By RXP-REX in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-24-2007, 07:27 AM
  5. 99 SLTH Wiring Diagram
    By ph2ocraft in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 10-22-2006, 06:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •