Results 1 to 4 of 4
  1. #1
    Banned User
    Join Date
    Aug 2006
    Posts
    1,236

    2001 Virage 780???



  2. #2
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    The poor thing.....(shedding a single tear)

  3. #3
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400

    780

    wonder how they tied all the electronics together,should have painted the motor blue,that red is ugly

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Interesting, I'm curious as to what he used for engine mounts and/or a bed plate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 VIRAGE TXI- running lean
    By SMOKEWAGON in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-05-2007, 08:18 AM
  2. Need help with a 2001 Virage Tx
    By grammylinny in forum Polaris Open Discussion
    Replies: 27
    Last Post: 07-01-2007, 08:06 PM
  3. 2001 Virage Motor Stall
    By ddleigh in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-20-2007, 05:23 AM
  4. 2001 virage engine frozen
    By jeeprunnr in forum Polaris How To & FAQs
    Replies: 28
    Last Post: 12-18-2006, 04:27 PM
  5. 2001 virage engine and jet pump removal
    By jeeprunnr in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 12-08-2006, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •