Results 1 to 2 of 2
  1. #1

    thanks for the help

    hey everone i found the leak it was the hose leadind to the exhaust. that takes water in. but the ski will still not run rithrt still runs 4000 rpm mabe a litte higher like 4500. plese need this fixed if any one is around me i will pay for them to look at it in st. louis mo area. i got great comprasion too its like 150 psi

  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Southeast Ohio
    Please remind us what year/model of ski this is? Are there any warnings on the dispaly? Have you checked the crank index? Let us know what you find.

    I am sure that you could fix this yourself with a little mechanical ability, a manual, and the help of the guys on here.

    Good luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. YYESSSSS finally figured it out, thanks for the help..
    By ukdude in forum Polaris Tech Tips and Info
    Replies: 5
    Last Post: 08-07-2012, 11:16 AM
  2. whats the bov hose size to order tbolt clamps 2011 fzs thanks for the help
    By camaro630hp in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-20-2012, 08:31 PM
  3. JacRae thanks for the help
    By stingray152003 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-27-2008, 02:14 PM
  4. Thanks for the help
    By RVRM in forum 4-Tec Performance
    Replies: 0
    Last Post: 01-09-2007, 11:55 PM
  5. Thanks for the help
    By Spager in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 12-19-2005, 04:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts