Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    polaris msx 150 burning oil limeted rpm help plz

    hello i have a polaris msx 150 and i was in the sea on it started it was runnin fine then after about 2 mins of running it went limeted to 4200rpm usually the overboost limiter so i assumed it was a blocked pipe with the turbo waste gate again but thats clear i have noticed when i start it up its atually smocking loads burning oil witch a 4 stroke should obveosuly not do and is always limeted it has used all the oil that was in it and non is showing on the dipstick can someone please help me out thank you


  2. #2

    Join Date
    Oct 2006
    Location
    Buffalo, New York
    Posts
    34
    when you checked the oil did you run the engine for 30 second before checking the level?

  3. #3

    oil

    yes i checked the oil after the engline had been runnin anyone any idea what this prob is

  4. #4

    Join Date
    May 2007
    Location
    Middleburg,FL
    Posts
    359
    +1
    1
    When was the last oil change(every 25 hours). Have you checked your turbo pipes for oil. If you overfill this motor it will suck oil back to the intake of the turbo. Then the oil get all over your senors and clog your intercooler. If there is no oil in the intake and you start with the correct oil level with blueish green smoke. Then you are burn oil that is passing by the rings or valve seats. That would be the other cause of oil loss. I have over filled My Msx and have had to pay for it. I'd check the intake system first. If it were me. Where is SUPER J.

  5. #5

    oil burning

    thanks for the edvice can enyone please help me anymore about this oil burning maby go into more detail on wat i need to do from the last post help needed asap thank you

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by ln69bt View Post
    thanks for the edvice can enyone please help me anymore about this oil burning maby go into more detail on wat i need to do from the last post help needed asap thank you
    Could you re-cap your story so far?
    What happened, when, in what order?

    Was the engine operated with very low oil levels?

    Has cylinder compression been checked?

    How many hours on the motor?

  7. #7

    oil burning reply

    hello i was on the sea about 6 months ago and it was running fine. i took it out the next week started it up and it seemed to be fine but i pulled it back and it was stuck at around 4800 rpm limted yet again but this time i took it out the water and when i started it i noticed it is atually burning oil blackish smoke comming out the back all the time and within 1-2 mins or running like this it uses all the oil in its oil tank i put compretion tester on both cylinders and they was both exactly the same also it has no trube starting or ticking over its just limeted and burning loads of oil please help thank you there is around 23 hours on the motor i think and its 2004

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275

    MSX 150 empties the oil resevoir rapidly, oil in exhaust

    Quote Originally Posted by ln69bt View Post
    hello i was on the sea about 6 months ago and it was running fine. i took it out the next week started it up and it seemed to be fine but i pulled it back and it was stuck at around 4800 rpm limted yet again but this time i took it out the water and when i started it i noticed it is atually burning oil blackish smoke comming out the back all the time and within 1-2 mins or running like this it uses all the oil in its oil tank i put compretion tester on both cylinders and they was both exactly the same also it has no trouble starting or ticking over its just limeted and burning loads of oil please help thank you there is around 23 hours on the motor i think and its 2004
    If the motor is sucking up all the oil in the resevoir in a couple of minutes, then there is something very wrong.

    Perhaps someone on the forum who is familiar with these turbo 4-strokes could comment on what might be happening.

  9. #9
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    Are you getting the 'Check Engine' light? Have you noticed any water, or engine coolant, in the oil?

  10. #10

    oil burning

    i cant really see in the oil tank to see if theres any water in there but the red light and check engine light is on all the time yes and its rpm is limted .

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Polaris MSX 150 no spark no start ****Help****
    By spray&Splash2011 in forum MSX/Matrix
    Replies: 6
    Last Post: 08-01-2015, 06:05 AM
  2. Polaris MSX 150 Low oil pressure
    By Cmizzer in forum MSX/Matrix
    Replies: 7
    Last Post: 08-19-2011, 10:24 AM
  3. Replies: 12
    Last Post: 07-05-2011, 10:44 PM
  4. My Polaris MSX 150 doesn't work! Please Help!!
    By kiwi polaris in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-22-2010, 08:17 PM
  5. polaris burning oil limeted rpm form 2 help !!
    By ln69bt in forum MSX/Matrix
    Replies: 0
    Last Post: 03-23-2008, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •