Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38

    780 piston/domes pics....not to good!

    Ok, my original post on running problem can be found here. http://greenhulk.net/forums/showthread.php?t=28090

    Let's see if my pics turned out.

    Mag Piston eroded from center to exhaust port


  2. #2
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Mag dome



  3. #3
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Center



  4. #4
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Center dome



  5. #5
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Pto



  6. #6
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Pto dome



  7. #7
    Lean machine! Z

  8. #8
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Yeah. How long do you think this had been going on? Ski has 187 hrs on it.

  9. #9
    Not very it doesn't take long to do that especially under a load like towing tubing or wide open throttle Z

  10. #10
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    So do you think this is a possibility? I bought it with 130-110-120 psi mag to pto. I ran it for 4 hours on first trip and 6 hours second trip. Could the fuel system and carbs have been clogged and gummed up enough to do this in 10 hrs.? This is the first 2 times it's been run since last year w/previous owner.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Look at WSM platinum Pistons, for anyone looking to rebuild pics
    By Fenderjack in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-17-2015, 10:23 AM
  2. help evaluate borescope pics. about to stick piston?
    By fivespeedsteed in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 10-11-2012, 08:44 AM
  3. Replies: 2
    Last Post: 03-17-2011, 11:15 PM
  4. WTB WTB: good used 780 piston/rings shipped overnight
    By cameron da river rat in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-28-2010, 02:02 PM
  5. to Ring or not to ring .....slx 780
    By desertmariner in forum Polaris Open Discussion
    Replies: 23
    Last Post: 01-05-2009, 07:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •