Results 1 to 6 of 6
  1. #1
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846

    Surging Question

    Went out today and Ill be damned what a week can make.I dont know what happened but its like my ski desided it didnt want to run worth a [email protected] today..Memorial day weekend it ran great with Danny running a 78.5 at 8160 RPM on it.Today i take it out and it acts like its Surging at high RPMs.It would run fine one minute 8160-8180 and then it would fall on its face 7980-8120 then it would run great again unless i grabbed the throttle wide open..Question is is this a sign of a boost leak or are the spring washers in the SC needing to be replaced..Any info would be greatly appreciated..Thanks

    Scott


  2. #2
    friebe1's Avatar
    Join Date
    Mar 2006
    Location
    Clovis, Ca
    Posts
    224
    Sounds like clutch slippage, what is the slip tension at now? I assume you have metal washers?
    Steve

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Ya steve i have the metal washers.Only have 4 hours on them but they are hard riddin hours .I figured it is the SC slipping just wanted to be sure before i ordered the new spring washers.I couldnt tell ya the tension right now .we just got home a little bit ago so the SC is still in the machine.

    Thanks
    Scott

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846

  5. #5
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    dunno, both steve and tommy had to retorque their SC's because of spring washers loosing tension....

    Could be slippage, thats why i tossed in a BOV...Ran it at mudbug with no chirping...and no loss of boost...

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Ya i have the riva S3 bov i kinda think that the spring washers need re-torqueing.But the SC only has 4 hours on it since i got it back from Jerry
    .Guess that doesnt mean anything considering i ran it pretty hard at Danny palozza.then ran it hard again this weekend.I have the spring washers on order from Dockside should be here tomarrow..Just have to order the tools from jerry and take the HOW TO SC class.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question on R&D SHO/FZ Surge Protector Kit
    By 64physhy in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-25-2010, 11:10 AM
  2. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  3. question on ported 1300...idle surges after having water in engine...i
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-23-2009, 09:06 AM
  4. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  5. Compressor Surge Question...Please Help!
    By left coast girl in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-23-2007, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •