Results 1 to 9 of 9
  1. #1

    Join Date
    Jun 2007
    Location
    West Virginia
    Posts
    61

    Question about mfd

    Hi im new here just bought my first ski a 95 sl 750.The thing runs great at top speed,when im at a dead stop gun it it wants to bog down,but if I pull the choke let go gass it it takes off great,also my mfdisnt working right it has some of the numbers like clock its dark but is missing parts of it!?Could it be a fuse or does it need reset?Oil level i can see,but the gas side dosnt show also it has a red flashing light in the middle any suf would be ap. thanks Gary


  2. #2
    Welcome to the boards!!
    It sounds to me like your mfd may need to either be replaced or cleaned. Weatherby is doing that (repairing them). As far as pull the choke out and go. I will say you have a high speed jet stopped up, maybe more. Clean, rebuild the carbs and replace all of the fuel lines.. Maybe even the selector. Cheap insurance.. I am sure that will take care of your issue, Dont run it the way it is you might run lean and Burn a piston, maybe even worse.. I am sure others will chime in on this also..

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Welcome to the Hulk. If the MFD is displaying anything, the fuse is fine. I would try the reset procedure in the tech section. If it's bad, send it to Wetherby like he said.^^^^ As for the bogging, you may have a jet clogged or pop off problem. Maybe rebuild the carbs, or at least go through them. They are quite easy to do, just count the adj. screw turns and put them back when done cleaning/rebuilding. Each carb will be different, so record the turns and which carb it was.

  4. #4

    Join Date
    Jun 2007
    Location
    West Virginia
    Posts
    61
    Thanks for the tips!I did get it apart and cleaned it,it is reading better then it was,I think I might just need to clean a little more after work tonight . PS This site rocks!!!!!!!!!!!!

  5. #5

    Join Date
    Jun 2007
    Location
    West Virginia
    Posts
    61
    Now that ya can read the mfd better it keeps saying fuel???what would that mean?

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Your fuel float probably sunk.

  7. #7

    Join Date
    Jun 2007
    Location
    West Virginia
    Posts
    61
    How do I unsink it..lol

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Remove the sender remove the bottom plate. Replace the float.

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Someone said that they soaked there's with carb cleaner and let it dry for a few days, and supposedly it works again. I didn't try it but worth a shot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Questions about MFD 95 Sl750
    By Firefighterarcher in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-02-2010, 12:01 PM
  2. Questions about MFD 95 Sl750
    By Firefighterarcher in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-10-2010, 07:51 PM
  3. 94SL MFD - Question about turning off
    By howie099 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-22-2007, 12:26 AM
  4. Question about RXP Cooloant Tank
    By joeg in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-18-2005, 09:55 AM
  5. Questions about the IC install.
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-04-2005, 08:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •