Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    02' Virage... need help.

    02' virage not running...looks to be good fuel and pulse to injectors but nothing into cylinders..will try to run if I put a little fuel through intake....
    Last edited by pistolsdown; 06-12-2007 at 04:12 PM.


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Welcome to the Green Hulk Forums!


    Have you checked the compression? If so, what were your readings?
    Can you give us a little more back ground for the ski? Did it just start doing this? Hace you checked the fuel pump? Are you getting good spark.

    Any additional info will help us.

    Let us know what you find.

  3. #3
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Check fuel Pressure .Easy check for fuel pressure is to put your hand around fuel line and press start button .Fuel line should swell .If not no fuel press .You may find the regulator has fallen into the fuel tank from its original position
    Cheers

    Bernie

  4. #4
    yes..has good spark and fuel pressure.

  5. #5
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Do you have a multi meter ?.Check voltage of battery at cranking .Need 10.5 volts .You say it runs for a second on some fuel in the manifolds?
    If so the injectors don't appear to be working.They should go tack tack on cranking .Feel them while cranking .Get back to us .How didi you check spark ?



    Cheers

    Bernie

  6. #6
    battery power is good, and I swear I can hear the injectors clicking but I'm getting no fuel in the cylinders

  7. #7
    found that voltage at injectors should be 22-25dc..I only have 10-11 volts.

  8. #8

  9. #9

    Thumbs up

    I guess I'm looking at a stator or EMM...not sure just yet,. thanks for the help......

  10. #10
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Check fuel pressure .Check earths

    Bernie

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Picked up 02 Virage 800 - need help
    By UnityRacing in forum Polaris Open Discussion
    Replies: 14
    Last Post: 01-05-2015, 08:06 PM
  2. Need Help on '02 Virage TXi Starting Problem
    By bluedevil60 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-26-2009, 12:06 PM
  3. '02 Virage 800i fuel injection questions... need HELP!
    By ProXR 440 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-17-2009, 01:07 PM
  4. Need Help on 02 virage 700cc
    By jeffholloway96 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 12-19-2007, 07:48 AM
  5. 02 virage 1200txi help bogging
    By john8873 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-24-2007, 12:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •