Results 1 to 3 of 3
  1. #1
    jetskr's Avatar
    Join Date
    Jul 2005
    Beaumont, Texas

    burn up bilge pump

    When I got my 03 1300 the bilge was not coming on - I couldnt hear it when I turned the motor off so I replaced it with the same kind and it has worked now for about 4 separate outings of riding but since coming home from Mudbugs I noticed that its not coming on. I talked to WFO and he mentioned I should just wire it direct to a manual switch so I can use it when I just want to check. Great idea. Question though - Does anyone know why it has now burn up 2 bilge pumps? Total hours on ski is just 30 hours. I did wire it direct to the battery to see if it worked but does not.

  2. #2
    Like a chimp with a ball-peen hammer smackwave's Avatar
    Join Date
    Dec 2005
    Annapolis, MD
    I would have to say you've got a bad connection somewhere or a flakey fuse. Most of the time the bilge pumps will outlast your ski.

  3. #3
    Chine Walker
    Join Date
    Nov 2006
    Rule has a 3 year warranty no questions asked. Mine was replaced after the dealer broke the inlet fitting. The rep asked me what year the boat was and after realizing my '03 was within the waranty period she sent me a new unit. Ask for Barbara in customer service; very pleasant individual.
    Another option is the 750gph unit which is only a 1/2 " taller and fits perfectly in the sock bracket (doesn't come with OEM connector which you would have to splice in from the original unit)


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Bilge Pump install
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-27-2014, 10:04 AM
  2. How-To: Bilge pumps
    By USS RXT in forum Sea Doo How To & FAQs
    Replies: 59
    Last Post: 03-16-2010, 10:02 PM
  3. Bilge Pump
    By Red Devil in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-09-2005, 10:01 AM
  4. Installing a bilge pump in my RXT
    By ToeSurf in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-03-2005, 01:00 PM
  5. For those of you looking to put a bilge pump in your Ski....
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-22-2005, 12:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts