Results 1 to 4 of 4
  1. #1

    f12 flashing oil light??

    ive got an 03 f12x ive been trying fix, flasking oil. ive replaced the high and low switch, changed and checked oil level. checked starter solenoid bolts( per honda bulliten) checked battery terminals. still flashing.

    the last f12x i did (i work at a shop) replaced all that and pulled the motor replaced oil press relief valve(per honda) didnt fix it.. then i replaced wiring harness and battery positive terminal(also per honda) no more flashing oil light. i really dont feel like replacing wire harnesses on every flashing oil light honda.. anyone had this problem and what was the fix for yours?? im not having fun with hondas between flashing oil lights and all the turbo issues with the wage gate controller and map sensor... i work at a shop in florida so alot of it has to do with salt water getting into connectors im sure, but ive checked connections ands put dielectric grease everywhere, no help..
    any help out there?


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    pretty common problem on the WGS. check the FAQ here for my quick check next time you get one in.

    The high pressure oil switch is grounded when triggered Normally open when not. use a ohm meter to check, the harness would have a short somewhere if the switch checks good

    The Low pressure switch triggers the ECU so same thing but ohm out the harness at the ECU. replace as necessary.basic stuff.

    Shawn

  3. #3

    Join Date
    Apr 2007
    Location
    Birmingham ,AL
    Posts
    88
    +1
    3
    Hey Buddy. Just a little question on the oil light problem.Was the replacement lower harness the cure for this problem? I have an 06 F12x G-scape that seemed to have a bad connection in the fuse box. Some times it would start and other times it wouldn't.Also the oil light was flashing all the time with correct amount of oil in engine. I ended up replacing a fuse in the lower harness fuse box( although the old fuse wasn't broken) and it has started every time and the oil light went away for the last 6 hoursof ride time. I might add before I replaced the fuse.. if I pulled the harness wires(right at the fuse box) upwards or towards the battery I would hear the ignition (fuel pump activate)come on and it would start.Without pulling wires like I did -No ignition-This is how I figured out maybe a bad fuse connection in that area.
    Anyway I'd like to know if your new harness fixed the oil light problem . I have a feeling this may cure both the oil light prob and my ignition problem as of right now. It wont start again and oil light is back on. New fuse is not helping.Thanks in advance man


    Quote Originally Posted by faster7581 View Post
    ive got an 03 f12x ive been trying fix, flasking oil. ive replaced the high and low switch, changed and checked oil level. checked starter solenoid bolts( per honda bulliten) checked battery terminals. still flashing.

    the last f12x i did (i work at a shop) replaced all that and pulled the motor replaced oil press relief valve(per honda) didnt fix it.. then i replaced wiring harness and battery positive terminal(also per honda) no more flashing oil light. i really dont feel like replacing wire harnesses on every flashing oil light honda.. anyone had this problem and what was the fix for yours?? im not having fun with hondas between flashing oil lights and all the turbo issues with the wage gate controller and map sensor... i work at a shop in florida so alot of it has to do with salt water getting into connectors im sure, but ive checked connections ands put dielectric grease everywhere, no help..
    any help out there?

  4. #4

    Join Date
    Jul 2012
    Location
    Kathleen, FL
    Posts
    55
    Quote Originally Posted by NitroShark View Post
    pretty common problem on the WGS. check the FAQ here for my quick check next time you get one in.

    The high pressure oil switch is grounded when triggered Normally open when not. use a ohm meter to check, the harness would have a short somewhere if the switch checks good

    The Low pressure switch triggers the ECU so same thing but ohm out the harness at the ECU. replace as necessary.basic stuff.

    Shawn
    So NitroShark
    If I ohm out the high pressure switch and it ohms out as a dead short then the switch is bad?
    And now the ski is in limp mode as soon as it starts could that be the high pressure switch as well?
    Thanks in advance.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha 2008 ar212x oil light flashing on one side
    By foxrider56 in forum Yamaha Sport Boat
    Replies: 4
    Last Post: 05-26-2015, 09:56 AM
  2. My 2001 Polaris Virage TXI low oil light flashes....
    By MikeMac in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-11-2014, 04:11 PM
  3. Oil light flashing, but no code showing
    By seadoo65 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-25-2013, 03:31 PM
  4. 2005 R-12x oil light flashing
    By cigarlust in forum Honda Open Discussion
    Replies: 10
    Last Post: 04-08-2013, 03:00 PM
  5. Red Oil light flashes and goes to rev limiter mode
    By bmmoore42 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-11-2011, 08:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •