Results 1 to 4 of 4

Thread: Lots of water?

  1. #1
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342

    Lots of water?

    When I got done riding today I pulled the plugs and had a full stream for 30 seconds which is not usual....most of the time i had a little tiny bit run out and thats all. What do I need to check to make sure its not the carbon seal? and if it is how much does it cost to get it changed because I heard it was hard to change


  2. #2
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    958
    +1
    9
    Dude,my 04 rxp did this but alot more water was coming in,it was the motor mounts rubber getting soft that caused my engine to push forward and open a gap between the carbon seal and the seal ring that holes on to the shaft,almost sunk.I replaced the mounts a no problem now.

  3. #3
    Tennessee's Avatar
    Join Date
    Dec 2005
    Location
    Mt. Juliet, Tn
    Posts
    502
    +1
    2
    It could be from a bunch of places. Fill it up just over the carbon ring and see if it comes out anywhere. Try starting it and look look look. You could just have a hose that wore a hole in it. Take the seat off in the water and make a few runs and see if you can see where it might be comming from before you take it somewhere to get it fixed. Could be a simple fix. Good luck1

  4. #4
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342
    Quote Originally Posted by buddydoo View Post
    Dude,my 04 rxp did this but alot more water was coming in,it was the motor mounts rubber getting soft that caused my engine to push forward and open a gap between the carbon seal and the seal ring that holes on to the shaft,almost sunk.I replaced the mounts a no problem now.
    how were you able to tell this? and would it be a over night difference because yesterday it was normal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pro 785 took on a lot of water
    By Kerminator in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-16-2013, 07:36 AM
  2. Replies: 8
    Last Post: 09-21-2013, 05:43 PM
  3. ZXI 1100 taking on a lot of water....
    By ShawnTX in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 09-12-2013, 09:31 PM
  4. Replies: 29
    Last Post: 03-12-2012, 06:32 AM
  5. WATER IN ENGINE OIL~~~LOTS of WATER !
    By David_HX_RXP in forum Sea Doo Open Discussion
    Replies: 29
    Last Post: 07-15-2008, 03:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •