Results 1 to 9 of 9
  1. #1

    grinding the impeller

    got the fuel fixed on the 95 650 diagram worked great cranks and runs good now at idel there is a grinding sound from the pump truns over fine when the ski is off the impeller is grinding the wear ring and i dont know why the impeller is still good must have just stared but it does not do it when you give it gas can someone plz help me here. will it be fine or does someone know how to fix


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Running out of the water it sounds like a box of rocks!!! In the water you wont here it. Unless your wear ring is warping due to exfoliation.

  3. #3
    ok dont know what exflatction is but it has eat the edge of the impeller but what your saying is it becuase its out the water so it should be fine to ride

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Exfoliation is where the metal becomes distorted and expands from the inside out. If the wear ring looks good and your impeller clearance is good than let it rip!!!

  5. #5
    yeah had to take a file to the wear ring had to humps in it on the bottom got it smoothed out but still tring to get a new one so the pump is good thats all i need to hear

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    30
    How does the pump bearings feel? You may be hearing them.

  7. #7
    Breanings Feel Great The Edge Of The Pump Has Started Eating The Wear Ring Where The Humps Are

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    30
    Maybe time to consider a new wear ring. If it's out of spec, you will not get good performance no matter how the engine is running.

  9. #9

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 250x ultra,have anyone try to repitch the impeller?250
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-01-2007, 02:13 PM
  2. Replies: 11
    Last Post: 11-04-2006, 03:41 PM
  3. Taking off the impeller cone
    By Hecyan in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-20-2006, 11:18 PM
  4. How many mm's is the impeller alen bolt on the prop?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 09-22-2005, 09:40 AM
  5. Sand/Mud in the impeller
    By Gforce in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-06-2005, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •