Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Hi Everyone!

  1. #1

    Unhappy Hi Everyone!

    I'm John, Make a LONG story short, Im near suicide.just kidding, My New ULTRA today first time out would only run 57mph!!!!!!!!!!!!!!!!!!!!!! And blinked 58 a couple of times, Please don't get my wrong The boat was awesome out of the hole, and handeling in Lake Eris MI, very little spray in my face and very stable but after trading in my STX-15F that ran 63-64 all day long im very VERY upset with the ULTRA's top end!!! Is my speedo F-cked up?? I know I need to GPS it, but I don't have one yet PLEASE HELP! Big John


  2. #2
    Quote Originally Posted by SPEEDJUICE View Post
    I'm John, Make a LONG story short, Im near suicide.just kidding, My New ULTRA today first time out would only run 57mph!!!!!!!!!!!!!!!!!!!!!! And blinked 58 a couple of times, Please don't get my wrong The boat was awesome out of the hole, and handeling in Lake Eris MI, very little spray in my face and very stable but after trading in my STX-15F that ran 63-64 all day long im very VERY upset with the ULTRA's top end!!! Is my speedo F-cked up?? I know I need to GPS it, but I don't have one yet PLEASE HELP! Big John
    Yes the speedo in inacurate! I noticed that the speedo tops out around 57-58 too! You are definately going faster than what the speedo reads!

  3. #3
    Welcome to the forum Big John!

  4. #4
    Thanks Muddy!! Someone said to lossen the Speedo bracatte on the back of the boat, and try to lower the assembly a 1/4 of an inch??? Someone else said there could possibly be to much oil in my supercharger??

  5. #5
    GDM's Avatar
    Join Date
    Apr 2007
    Location
    Ahead Of You
    Posts
    389
    the speedo is about as reliable as miss cleo

    honestly if this isnt your first ski how can you be so naive in thinking that speedo is acurate


    .

  6. #6
    Quote Originally Posted by GDM View Post
    the speedo is about as reliable as miss cleo

    honestly if this isnt your first ski how can you be so naive in thinking that speedo is acurate


    .
    Miss Cleo!

  7. #7
    lol, I hear ya Bro, I guess you just kinda think thats one of the thing that would on the money?? I will try to lower the assembly sunday and make another run, I need to get a GPS, If a GPS reads??? 66, and my speedo reads 56, is it a major deal to get this calibrated to the right speed???

  8. #8
    GDM's Avatar
    Join Date
    Apr 2007
    Location
    Ahead Of You
    Posts
    389
    Quote Originally Posted by SPEEDJUICE View Post
    lI will try to lower the assembly sunday and make another run,
    i wouldnt bother ,then it will read 70 but you wont be doing 70 . better off getting a gps and forgetting about the speedo in my opinion


    was your 15f stock ? if it was i doubt you were doing 63 . the point i am trying to make is pwc speedos suck


    .

  9. #9
    Just a H-20 HO....Need I say More! Mykull's Avatar
    Join Date
    Nov 2006
    Location
    Northern Va/ SOBX
    Posts
    283
    Speedjuice, Congrats on the new toy, but just start off doing a forum search first before you panic and go read Skips blog on the teamoto site, its very informative!! Oil level in motor (not supercharger) has been known to be overfilled by dealers so check it, take off the rear seat mount and tighten up all the exhaust hose clamps (some have popped off causing it to die), if your speeds are slow on speedo just loosen up the mount on the back of ski and lower it. If it seems like it is cavitating to much take alook at the intake grate area/ tunnel for extra silicone or lack of in certain spots. Im sure there are some more things I cant remember off the top of my head so others can fill in my blanks.
    BTW..GDM some of us have run 70!!
    Last edited by Mykull; 06-17-2007 at 12:04 AM. Reason: spellin

  10. #10
    GDM's Avatar
    Join Date
    Apr 2007
    Location
    Ahead Of You
    Posts
    389
    Quote Originally Posted by Mykull View Post
    BTW..GDM some of us have run 70!!

    i know , im hoping to be there soon myself . once i get my rideplate back i think ill hit 70 , plus the bottom of my ski is a mess , globs of silicone everywhere



    .

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi everyone, first post and a question
    By ramstein in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-04-2013, 10:56 AM
  2. Hi Everyone!
    By mabguru in forum MSX/Matrix
    Replies: 23
    Last Post: 12-29-2012, 12:49 PM
  3. Hi everyone!!!!
    By ryandi2 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 08-10-2012, 03:42 PM
  4. hi everyone I come from Spain !
    By Impulses in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 12-29-2011, 03:38 PM
  5. Hi Everyone! (New Around Here)
    By YamaSHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 11-07-2008, 12:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •