Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2007
    Location
    Toronto / Grand Bend
    Posts
    129
    +1
    1

    '95 SL750: Reinstalling drive shaft but missing parts...

    So I took the engine out the weekend before last to remove the stator and fix the harness with the fried wire. Did that this past weekend and started to reinstall everything. All was going fine till I got to the part where I had to reinstall the driveshaft. The repair manual states that there is a bumper and o-ring that needs to go on at the back end of the driveshaft that inserts into the impeller. See parts 7 and 9 (thank you Partsland.com):



    When I removed the driveshaft those parts were not there. I checked and double checked. There was one of the bumpers on the engine end of the driveshaft but that was it. I did have my previous shop replace my impeller with a Solas about 4 years ago and I'm wondering if they mistakenly left those parts out or if they are not required for the after-market Solas impeller. My question is, do I need these parts? It has been running 5 years without them without a problem. The impeller and driveshaft splines look like new.

    Or maybe they did fall off when I disassembled it two weeks ago and they fell into the sand and I missed them (I've had to do this work at the beach on my beach cart but that's a topic for another time ). I ordered them this morning from partsland.com but I'm afraid they won't be in until next week and I'd hate to miss another weekend of not riding since our season up here in Canada is only 3 weeks long!

    Thanks to all who have given me advice on this project so far!


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Check for the bumper inside the impeller. If it's not there, you can make your own for time being from rubber of the same thickness as the one you have. Does the Solas impeller have a seal of it's own? If so run with it, if not you can most likely find an O ring at a GOOD hardware store.

  3. #3

    Join Date
    Jun 2007
    Location
    Toronto / Grand Bend
    Posts
    129
    +1
    1
    I looked in the impeller and there was no bumper or o-ring in there. I guess I could make my own and buy an o-ring... never thought of that.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    I think Solas uses there own seal and you do not need the o-ring.


    Detailed Description Fits Solas Blade Series ST. SF. YF. KA. KD. KE. KF. KG. PF. PA. TB. TC. PA.

    Unique shape is hydrodynamically designed to keep water flowing next to cone and into impeller blade, reducing cavitation. CNC-machined to precise specifications then blue-anodized for corrosion-resistance. Double O-ring inside keeps cone firmly in place; indented pry spots for easy removal. Can be used in any application that uses part #SL009.

  5. #5

    Join Date
    Jun 2007
    Location
    Toronto / Grand Bend
    Posts
    129
    +1
    1
    Quote Originally Posted by beerdart View Post
    I think Solas uses there own seal and you do not need the o-ring.
    I think this is for the Solas Concord Impeller and this is for the exit/hub end of the impeller. I think I have the super Camber IJK Series impeller and in question is the engine driveshaft side of the impeller and the o-ring/bumper that goes in there.

    I might poke around the Solas website and see if I can find answers there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Table of Polaris drive shaft lengths and part numbers?
    By K447 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-13-2012, 09:44 PM
  2. 95 slt 750 drive shaft bearing seal leaking!
    By lockaby32 in forum Polaris How To & FAQs
    Replies: 36
    Last Post: 06-04-2011, 12:08 PM
  3. drive shaft rubber missing.
    By birdgod in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-16-2010, 01:13 PM
  4. 95 sl750 what to do? fix - sell - part out?
    By acesinthehole in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-17-2009, 07:39 PM
  5. 95 sl750 what to do? fix - sell - part out?
    By acesinthehole in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-26-2008, 12:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •