Results 1 to 10 of 10

Thread: pisser?

  1. #1


    i have a 92' 650 sl and there is a rubber thing on the back of the back of the ski. it is under the grab rail on the left side. on the inside there is a short hose that looks to be broken where is that supposed to go? and what is its function? thanks
    Last edited by smartalec_87; 06-19-2007 at 04:19 AM. Reason: i have a new question and i figured out the old one

  2. #2
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Roanoke, Va


    Do you have any pics of it?

  3. #3
    Race, wreck, repeat delagem's Avatar
    Join Date
    Aug 2006
    Homer, NY
    Yes, that's the pisser. On my '92 it's connected to the little 1/4" barb on the top of the exhaust. Just gives you a quick visual that your cooling system is working properly.

  4. #4
    here are the pics

    just so u know that second pic is supposed to be rotated 90 degrees clockwise to look right
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 010.jpg 
Views:	48 
Size:	2.52 MB 
ID:	28397   Click image for larger version. 

Name:	Picture 011.jpg 
Views:	46 
Size:	2.21 MB 
ID:	28398   Click image for larger version. 

Name:	Picture 012.jpg 
Views:	49 
Size:	2.58 MB 
ID:	28399  
    Last edited by smartalec_87; 06-19-2007 at 06:49 PM.

  5. #5
    as you can see that barb on the exhaust is already attached to somthing else. (whoever had it before me has a 93 cooling system in it). is that correct or does that need to be changed and the line that is cut should run there. from what i could tell in the manul it looks like that exhaust barb is routed right. but i could be mistaken. please help
    Last edited by smartalec_87; 06-19-2007 at 10:54 PM.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH

  7. #7
    i have seen that diagram but the problem is that it looks like my cooling system was switched to a 93 and that line on the exhaust no goes to a tstat like. i dont know if you can tell in the pic i posted. so know i have no way of running that line to the back. I was wondering if i could use a t fitting or if that would mess up the tstat/pop off. thanks

  8. #8
    Xlint somone put one of these tstats in!

  9. #9
    yeah that is what it looks like. so now i have no way to use the pisser fitting in the back. unless using a t fitting would work without hurting anything?

  10. #10

    Join Date
    Nov 2006
    is it that you want to use the pisser? because it appears to be correctly plumbed. you could t it to the pisser if you wanted, but what i would do is just cap it off at #11 on the t stat housing and run your line to the pisser it is all discharge water anyway. just my thoughts, but when in doubt you can always leave it alone.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can you put a yami "pisser" on a seadoo?
    By TorquePhoto in forum 4-Tec Performance
    Replies: 22
    Last Post: 11-15-2006, 09:36 PM
  2. Question On Water Bypass Pissers
    By ABBOTT in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 09-20-2006, 02:46 PM
  3. Where do you Yami guys get your pissers from?
    By 05RXPnoob in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-30-2006, 05:03 PM
  4. Cosmetic Pisser Accessory.
    By ccassone in forum 2-Stroke Performance
    Replies: 4
    Last Post: 02-22-2006, 10:42 PM
  5. Watercraft Pisser
    By ramnj in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 10-06-2005, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts