Results 1 to 3 of 3

Thread: Parts Installed

  1. #1
    ArmyRXP's Avatar
    Join Date
    Jul 2005
    Location
    Ft. Drum, NY
    Posts
    259

    Talking Parts Installed

    Well all parts are on and S/C's updated with Jerry's washers and ceramic bearings. Took me about 2 hours to put two back in.

    Jerry,

    I have to say man that is one loud S/C now with the rear air from Riva. Took a little time to trim it to get the proper fit and was having troubles getting it on the S/C with the stock exhaust but put the silicone tube on the air intake then on to the S/C and it went right on. Thanks for the parts cant wait to get on the water hopefully tomorrow. I did put them both on the hose and ran them for a while and no leaks so all is well will see and will let you know.

    Thanks to everyone on this site it is a great source of information and How To's that make things easy for the first timer like me.


    Gary


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    NOOO.......THANK YOU!!!! :flag raising smiley here:

  3. #3
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by SeanCucf View Post
    NOOO.......THANK YOU!!!! :flag raising smiley here:
    I second that. I am just glad you are home and get to get out, ride, and enjoy life.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got my new parts installe today!
    By 1SloFZ in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 04-27-2011, 05:37 PM
  2. Riva parts installation
    By DSmith1178 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2009, 05:02 AM
  3. P-X Stage one parts installed- couple questions
    By pdxrealtor in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-25-2009, 06:41 PM
  4. Parts Instalation Help
    By josh_m in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-03-2008, 06:10 AM
  5. All Parts Installed but a small problem???
    By Full_Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-10-2008, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •