Results 1 to 6 of 6

Thread: 03 gtx s/c

  1. #1

    Join Date
    Jun 2007
    Location
    Madill,ok
    Posts
    13

    03 gtx s/c

    i have a small problem, last year i had my water craft serviced, oil,filter,plugs. i had over filled the oil and (before oil change) it was runnig about 55mph now it is running about 45mph, is there still to much oil in the s/c, to let it work,or do i need to change the plus agian? help, i would like to keep up with everyone else,
    Last edited by gamble; 06-20-2007 at 09:12 PM.


  2. #2

    Join Date
    Jun 2007
    Location
    Madill,ok
    Posts
    13
    should i take s/c apart and clean it?

  3. #3
    Looking for a job gtxsc03's Avatar
    Join Date
    Dec 2005
    Location
    St. Charles, MO
    Posts
    1,426
    Here's what I've learned.

    Check the oil with the engine warm and the ski level. It should be between the two bends in the dipstick. The oil itself doesn't get inside the s/c, but too much oil can bog the engine and kill top speed. If necessary, get a suction pump and remove oil.

    What are your RPMs at top speed? If you're cavitating or if you're turning 7600+ RPMs @45mph, check your wear ring and impeller.

    Check for obstructions in your intake grate and pump. Also look for anything that might be dragging in the water. OPAS paddles moving up and down freely? Reverse gate up and out of the way?

    What octane fuel are you using? On my ski, 87 octane = slower ski

    Change your sparkplugs.

  4. #4

    Join Date
    Jun 2007
    Location
    Madill,ok
    Posts
    13
    thank for the tips,i will give it a try. and get back with you,and tell you if it worked thanks,

  5. #5
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,199
    +1
    51
    55? You need to dump the warped plastic pump and upgrade to metal. My 03 could do 61-62 with a solas impeller, worx grate and sponsons.

    It's probably time to upgrade to a metal clutch in the supercharger.

  6. #6

    Join Date
    Jun 2007
    Location
    Madill,ok
    Posts
    13

    Lightbulb still runing slowwwwww

    I change the plugs & run two tanks 91 gas,still runs between 47 & 50 mph(6100 rpm) do you have any other ideas? the motor sounds very strong,and changed the oil,it is at the bottom bend of the dip stick,oil that is,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 03 GTX SC should see 70mph by spring!
    By 01xdime in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-10-2005, 02:01 PM
  2. 03 GTX SC opinions wanted........
    By 01xdime in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-13-2005, 11:56 PM
  3. Why did my 03 GTX SC beat an 04 RXP?
    By 01xdime in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-10-2005, 06:36 PM
  4. What's the good pump setup for a stock 03 GTX-SC?
    By Jarrett in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-15-2005, 05:17 AM
  5. A few pics of my almost finished 03 GTX sc
    By two2curupt in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •