Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    New problem!! Buzzing from electrical box/no start

    Well, I never made it to the ocean!! The ski started up fine the day before. Now, when I press the start button I get a buzzing sound from the electrical box where the CDI sits! I pulled the box and replaced the CDI and it still buzzes!! I remember the key'd battery switch was filled with salt water when the hull filled with water, and now I see alot of corrosion seeping out of it! So, I ordered another switch. I thought the starter was acting up but I removed it and it tested fine. The engine also turns over easily at the coupler. Does anyone have any other suggestions why the engine does not crank over?


  2. #2

    Join Date
    Jun 2007
    Location
    Harrisburg PA
    Posts
    111
    How did you test the starter? Will the engine turn over if you bypass the electrical box and hook the battery directly to the starter wire?

  3. #3
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    Try a different battery...it may have gone bad or isn't putting out enough volts. You need to have at least 10.8 volts coming out of the battery before it will start.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Have you tried by-passing the starter solenoid to see if the engine cranks over?
    If so do you get power to the red/yellow wire leading to the solenoid?
    If yes and by-passing the solenoid works, replace the solenoid.
    Did you clean all the grounds and power lines at the battery and engine/engine plate?
    Is there any corrosion in the electrical box under the board?

  5. #5

    its alive...again!!

    I bypassed the key'd battery switch and the thing started up!! There was no water in the box, thank god!! So, I ordered a new key'd switch from PSW, Inc. and as soon as that comes in..back to the ocean!!

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    30
    What key'd battery switch? Can you get a pic?

  8. #8

    Here's a pic of it

    This switch is attached to the electrical box tray, just above the battery
    Attached Images Attached Images  

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I'd be sunk as I'm good at losing things. LOL

  10. #10
    Jug Inspector
    Join Date
    Aug 2006
    Location
    Chicago Burbs
    Posts
    552
    Quote Originally Posted by 95SLT750PWC View Post
    This switch is attached to the electrical box tray, just above the battery
    You can buy those at auto parts stores or even Meijer.

    Bryan

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2-Stroke Plz Help! 98 GP800 Buzzing from fuse box and wont turn over
    By CrownVicNick in forum Yamaha Projects & Build Threads
    Replies: 1
    Last Post: 04-27-2013, 06:10 PM
  2. Replies: 12
    Last Post: 06-14-2012, 06:54 PM
  3. 2007 GP1300R wont start - no spark and noise from electric box.
    By Davryx in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-13-2011, 09:39 AM
  4. WTB WTB STXR/ULTRA 150 electrical box and started solenoid box
    By icerocket1286 in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 11-03-2010, 09:35 PM
  5. 96 sl900 buzz in electrical box
    By 5050bar in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-08-2009, 11:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •