Results 1 to 4 of 4
  1. #1

    putting jet pump back in a sltx 97 model

    i put a knew bearing housing and seals on the drive shaft.but now trying to put it back in it wont go the shaft lines up goes in then stops about a have 1/2 in left to go in.the screw get to were there just showing on the inside of the hull.been try to push it in but no luck.HELP.i want to go jet ski this weekend

  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    You have to line up both the PTO and the Impeller splines..And push real hard!!!

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Did you put good lube on the seal of the driveshaft? It sounds like it's hanging up where it goes into the impeller.

  4. #4
    thank got it back in thanks for the help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seadoo xp 2000 model jet pump problem with solas concord
    By brenhbjh in forum 2-Stroke Performance
    Replies: 8
    Last Post: 03-16-2012, 04:41 PM
  2. What to silicon seal when putting jet pump back on 97 SPX
    By crackofdawn in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-07-2011, 04:27 PM
  3. Replies: 10
    Last Post: 07-06-2008, 03:54 PM
  4. Will a 1996 SLTX Jet Pump fit a 1999 1050 SLTX?
    By 1996SLTX in forum Polaris Open Discussion
    Replies: 9
    Last Post: 10-24-2007, 09:28 AM
  5. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts