Results 1 to 4 of 4
  1. #1

    putting jet pump back in a sltx 97 model

    i put a knew bearing housing and seals on the drive shaft.but now trying to put it back in it wont go the shaft lines up goes in then stops about a have 1/2 in left to go in.the screw get to were there just showing on the inside of the hull.been try to push it in but no luck.HELP.i want to go jet ski this weekend


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    You have to line up both the PTO and the Impeller splines..And push real hard!!!

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Did you put good lube on the seal of the driveshaft? It sounds like it's hanging up where it goes into the impeller.

  4. #4
    thank got it back in thanks for the help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 06-05-2013, 07:58 PM
  2. I just put a pump wedge in and need a steering component
    By rcj600 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 04-26-2013, 11:36 PM
  3. Do I need to change the jet pump oil in a 1994 sea-doo gtx?
    By jim08 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-16-2012, 09:08 AM
  4. Repair for Broken Jet Pump Bolts in Housing
    By LaserLTV in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-06-2012, 05:59 PM
  5. What to silicon seal when putting jet pump back on 97 SPX
    By crackofdawn in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-07-2011, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •