Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: help??

  1. #1
    gotpurp305's Avatar
    Join Date
    Feb 2006
    Location
    Miami
    Posts
    102

    help??

    Soo my rxp was acting weird, vibrations, not going anywhere. I thought it was just some seaweed soo i reach under to take it out, but theres nothing there. i get out and call it a day.

    So i got home and i found this...


    its like this hard plastic but it goes all around and i have no idea how it got through like that


    any ideas on how to get it out ?


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by gotpurp305 View Post
    Soo my rxp was acting weird, vibrations, not going anywhere. I thought it was just some seaweed soo i reach under to take it out, but theres nothing there. i get out and call it a day.

    So i got home and i found this...


    its like this hard plastic but it goes all around and i have no idea how it got through like that


    any ideas on how to get it out ?

    I'm confused....what color is it? pictures?

  3. #3
    gotpurp305's Avatar
    Join Date
    Feb 2006
    Location
    Miami
    Posts
    102
    its white

    i posted a pic but i guess it didnt show

    heres a link

    http://i9.photobucket.com/albums/a59...1071335-00.jpg

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by gotpurp305 View Post
    its white

    i posted a pic but i guess it didnt show

    heres a link

    http://i9.photobucket.com/albums/a59...1071335-00.jpg

    I'm at work, and I can't access photobuckets (they are blocked!)

    can you attacha picture here?

    Sounds like you wear ring....need to pull your pump to see if its spinning....

  5. #5
    gotpurp305's Avatar
    Join Date
    Feb 2006
    Location
    Miami
    Posts
    102

  6. #6
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    WOW, that is white!

  7. #7
    gotpurp305's Avatar
    Join Date
    Feb 2006
    Location
    Miami
    Posts
    102
    yep

    think i have to pull the pump to get it out?

  8. #8
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by gotpurp305 View Post
    yep

    think i have to pull the pump to get it out?
    no picture came up, so you'll have to eithr retry or pull the pump...

  9. #9
    gotpurp305's Avatar
    Join Date
    Feb 2006
    Location
    Miami
    Posts
    102
    its not working so i put it up in the gallery

    heres the link

    http://www.greenhulk.net/gallery/dat...1071335-00.jpg

  10. #10
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    take a pic from the OTHER direction, from the intake grate towards the prop....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •