Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,254
    +1
    846

    another broken part!!

    check this out, i really dont knwo why or how this happened and the piece that is broken off made it all the way through the exhaust and out the back, so now i need a manifold too, im havin really good luck with this beast these days!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0111_143.jpg 
Views:	32 
Size:	607.7 KB 
ID:	1998   Click image for larger version. 

Name:	100_0110_141.jpg 
Views:	30 
Size:	667.9 KB 
ID:	1999   Click image for larger version. 

Name:	100_0109_150.jpg 
Views:	30 
Size:	757.9 KB 
ID:	2000  


  2. #2
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,254
    +1
    846
    sorry the files are so big, my gf's camera

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,421
    +1
    176
    mine has broken in the same spot 2 times now! what the hell causes this?
    It's covered under warranty tho.(non wearable part) or 50bucks under extended.

  4. #4
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,254
    +1
    846
    ppg is supposed to warranty it for me, glen said he was gonna port one for me for 100 bucks, so maybe that will be interesting, i dont think the exhaust was leaking past hthe clamp though, just not somethin you hear of everyday

  5. #5
    JD 1's Avatar
    Join Date
    Aug 2005
    Location
    St. Louis, MO
    Posts
    4,185
    +1
    88
    no big deal, they all do that

  6. #6

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Dido, they all do that. Jd1 I got it... I think I need to buy something else from you call me.

  7. #7
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,982
    +1
    41
    Mine has been like that for almost 2 years now...It is normal...I have no idea what causes it...I think it is like an "EDDIE" type heat current that forms there on some boats...And causes the alluminum to melt in that one spot...As I have said...you don't need to worry about it it I have seen it on almost every boat...it will not get any worse than that...And it is allways in the exact spot!!..I wonder if it is in the casting of the manifold on some boats??

  8. #8
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,519
    I just replaced mine . Had the same wear. I don't reccommend letting it go too long though. The intense heat not only caused the wear at the end, but actually melted some of the baffles inside my waterbox. I found this out when there were pieces of the baffles actually wedged in my through hull exhaust tube. The ski wouldn't run. Warranty took care of most parts.

    -Brendan


    BTW - I have a new oem muffler/waterbox for sale if anyone needs one.

  9. #9
    daverxp4's Avatar
    Join Date
    Aug 2005
    Location
    montreal,canada
    Posts
    1,323
    seadoo02xp how did you find out this problem you said you saw pieces come out of the exaust or you just decided to cheke this or you are doing a upgrade on another performance part?

    BDNJ you mentioned that it got stuck in your thru hull exaust wouldent this melt your pipe and sink your ski?

    just asking this as i still have 2 more years of warrenty and if i should look further into this problem

  10. #10
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Wow this seems more common the clutch failure. Looks like I'll add this to the PM list for every oil change

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another Broken Bow Oklahoma Weekend....
    By Ultra Junkie in forum Southwest
    Replies: 3
    Last Post: 08-14-2007, 10:42 AM
  2. And yet another broken intake grate
    By fullboogie in forum Yamaha PWC Performance (2-stroke)
    Replies: 130
    Last Post: 06-20-2007, 08:43 PM
  3. Broken Part Found In Hull HELP!
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 14
    Last Post: 03-14-2007, 04:13 PM
  4. Replies: 0
    Last Post: 12-18-2006, 08:42 PM
  5. Replies: 0
    Last Post: 12-18-2006, 08:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •