Results 1 to 8 of 8

Thread: Chuging Along

  1. #1

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3

    Chuging Along

    Greetings--

    I drove back home from HOU to LVW this weekend to ride the Doos (ok ok .. to see my g/f...LOL) out at Lake O' The Pines. This is the second time we've gotten to take them out this season. First time they ran fine-- burned through 3/4 of the old tank of gas. Filled them both up $$$ and headed out.

    This time we ran into a little problem and I'm looking for some input. Her's started fine, idled fine but ran like crapola. When given the throttle, it would run rough and surge-- running slow, then pick up. After calming her down-- she was wailing "I just know its the superthingie going out....", I pulled two of the plugs. They looked OK-- nice and white/grey, not burnt.

    I ran it around at about 3500rpm and it would run rough, surging from 3500 to 2500 up and down. I kept it at around 3500 and it finally got a little less rough. A little more throttle and over time it got to where it wasnt too rough. About 15 min of this-- while all the time she's out on mine zooming by... ahmmmm.... and it finally seemed to clear. I ran it at cruising speed for another 15 min or so and all appeared well the rest of the day.

    Surely not bad gas-- both skis had the same gas. Stopped up injector perhaps ? or ??


  2. #2
    Could be an injector or a low battery. Check the battery.

  3. #3

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Greetings--

    Battery checked out OK-- seems to be charging, also.

    Should this happen again, how does one go about checking/clenaing an injector ?

    Do folks put a fuel filter inline somewhere ?

    Thanks--

  4. #4
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    change the plugs.. mine ran like you describe, new plugs did the trick

  5. #5

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    OK- It did it again -- changed the plugs after I got it back in. We took them out again a week or so later-- same problem--

    I ran it for 30 min or so and it finally cleared up for the most part.

    We're going to try to get out again this weekend-- I hate to have to spend 30 min limping around while Robin's zooming by on mine LOL

    Other suggestions ?

  6. #6
    jaycee's Avatar
    Join Date
    Jun 2007
    Location
    Rochester, NY
    Posts
    481
    Have Robin limp around while you go zooming around

    Is it still under warranty???

  7. #7

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Quote Originally Posted by jaycee View Post
    Have Robin limp around while you go zooming around

    Is it still under warranty???
    Yeah right-- THAT'LL work !! LOL

    Its still under extended maintainence- Somthing ring a bell ? I dont have a lot of confidence in our local repairing dealer.

    We are moving to Houston at the end of Sept through. Can someone suggest a good dealer around there ?

  8. #8

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Update--

    I changed the plugs again just in case-- easy, cheap possible fix.

    We got it out at a friend's place in Nacogdoches-
    YES! Finally-- Robin's ran right. RIght through a nasty patch of hydrilla that stopped it up !! But-- spark plugs were the fix !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How's the Ultra250 work coming along.
    By Hydrotoys in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 07-06-2007, 09:56 AM
  2. We've come along way!
    By Firefighter in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 03-12-2007, 03:06 PM
  3. moving right along
    By TxVirageTx in forum Polaris PWC Performance
    Replies: 3
    Last Post: 09-14-2006, 10:27 PM
  4. How is the Bayou Princess-mobile project coming along?
    By Yuji in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-19-2006, 02:50 PM
  5. How`s Shibby coming along with his weight gain?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-11-2006, 05:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •