Results 1 to 8 of 8
  1. #1
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39

    Should I use the cone or not.....

    I am going to install a Solas 14/19 on my RXP this spring.
    Should I use the green Solas cone or should I stick with the stock one.

    Thanks,
    Rob


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,443
    +1
    182
    The Green one is fine, is you wire brush the threads, and use red locktite. The green cone usually dosent go in very well the first time. check yours.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,341
    +1
    2,494
    I use the green cone on mine with the red loc tite. Holds up great.

  4. #4
    daverxp4's Avatar
    Join Date
    Aug 2005
    Location
    montreal,canada
    Posts
    1,323
    Quote Originally Posted by psycho rxp
    The Green one is fine, is you wire brush the threads, and use red locktite. The green cone usually dosent go in very well the first time. check yours.
    i used the original one my dealear actually tried to put the green one but couldn't he had a hard time screwing it on it onlt threaded inn a turn and half.
    did i do a mistake by putting the original?
    it's not too late yet to take it apart

  5. #5

    Cone

    There was a story at one time that the stock rubber boot went mushroom shaped at 70+ mph. Dont know if it is true.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,341
    +1
    2,494
    I switched to the solas green cone when i started mushrooming my stock rubber cones.

  7. #7
    Quote Originally Posted by Green Hulk
    I switched to the solas green cone when i started mushrooming my stock rubber cones.
    How does that happen?...PR...

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,341
    +1
    2,494
    extreme water pressure at 75+ mph.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Use solas nose cone or not
    By pete71 in forum 4-Tec Performance
    Replies: 29
    Last Post: 09-09-2013, 10:38 AM
  2. Old Thoughts - Remove the hook or Not
    By tchies in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 09-19-2007, 09:41 AM
  3. 1996 SLTX To Pull The Engine or Not To Pull The Engine
    By 1996SLTX in forum Polaris Open Discussion
    Replies: 70
    Last Post: 06-27-2007, 02:15 PM
  4. nose cone or not
    By shhr in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 04-05-2007, 08:51 PM
  5. To seal the pump or not ?
    By mtrager in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 03-23-2007, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •