Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    spd5535's Avatar
    Join Date
    Jun 2007
    Location
    MN
    Posts
    263

    What Impellers Are Recommended?

    I've got a 06' Utopia w/ twin 155 HP 4Tec engines. I gotta swap out the stock wear rings for yes, more stock wear rings (I was told that there are no SS ring avail. for this setup.) But my question is, as long as I'm replacing the wear rings I might as well replace the impellers. What's a good replacement impeller for the 06' Utopia where I would get better performance? Solas Concord? Also, I don't know what pitch it currently is, so what does everyone recommend??


  2. #2

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    I haven't noticed many other Utopia owners on this board, but from my recollection, the Solas Concord 11/19 is recommended for a stock 155hp jet. There are a couple of Speedster 310hp members here that might be able to chime in.

    -Scott
    '07 Speedster 150 SCIC

  3. #3
    I'm in the same boat and have already purchased two 11/19 solas and will probably have time to install them next week and test. If you can wait I will report back then.

  4. #4

    Join Date
    Apr 2006
    Location
    Tarpon Springs, FL
    Posts
    72
    Im in a 07 Utopia and Im curious as well. I've looked and I am unable to find what pitch the stock impeller is at, anyone know?

    edit: After looking at Sola's website it looks like the suggest the Concord 14/19 pitched blade. Why did you go with the 11/19?
    Last edited by DSquare; 06-26-2007 at 03:08 PM.

  5. #5
    spd5535's Avatar
    Join Date
    Jun 2007
    Location
    MN
    Posts
    263
    I was told that Solas' website is wrong and that it's supposed to be the 11/19. I guess I'll stay tuned and see what Doozer says next week.

  6. #6

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Yeah, even the supercharged boats can't turn a 14/19 properly without some mods, definitely a mistake. Glad to see there's more Utopia owners here than I thought! I'm curious too; I almost got the 11/19, but opted for the 13/18 instead.

  7. #7
    Test run on 07 Utopia stock about 25hrs. Altitude 2200 ft and 75F
    Before update top speed was gps 49.8 mph with Port engine maxing out 7400rpm and starboard 7200. I have run against another stock 07 and our speeds were about the same. Differences beween 06 and 07 I have found that the 06 does not have the rope guard around the shaft. The way it is bolted inside the 07 the gaurd probably causes some turbulence and the protector takes up volume from the intake. From reading other posts the 06 seems to run a few mph faster. From other seadoos I have run rpms pick up about 150 to 200 rpms higher down at sea level.

    After installing Solas 11/19 with refreshed wear rings port engine 7000 rpm starboard 6800. I just went on the river to test so even going upstream and down stream to get average max speed I guess around 46-47mph. If you hammered it wot from stop it would spinout for fraction second and then start pulling hard. Midrange pull felt better than stock, like when driving tight s turns to loose a tuber.

    Overall I will stick with stock impellers. The Solas 11/19 I will get repitched to better match the engines.

    Also the hub diameter on the intake side of the solas is smaller than stock so that it steps inwards behind the shaft protector. 06 with no protector the water flow would probably be smoother.

  8. #8
    spd5535's Avatar
    Join Date
    Jun 2007
    Location
    MN
    Posts
    263

    06' Utopia SE Wear Ring/Impeller Upgrade

    06' Utopia SE stock. I was running about 55-56 mph and touched 57 mph once. It must have been the 40 mph wind gusts that that were helping me . Being new to jetboats I accidentally sucked up some sand and rocks. My speeds slowed 6-7 mph so reading the posts on GH I figured it was time to change out the wear rings. And as long as I was going to do that I might as well upgrade my impellers. I went with stock wear rings (no stainless available .), new pump gaskets, and Solas Concord SR-CD-11/19 impellers. The dealer wanted $500 for the job so being a little mechanically inclined I figured I would take it on myself. It was very easy to do; I just followed the instructions on the following threads:

    http://www.greenhulk.net/forums/show...92&postcount=1

    http://www.greenhulk.net/forums/showthread.php?t=808

    Tools/Items I Purchased
    Metal Tube (breaker bar)
    Vice
    Impeller tool
    12 mm Allen
    Metric Allen set
    SeaDoo bearing grease
    17 mm deep well socket
    6 mm allen socket
    Blue Loctite
    Loctite 518 (gasket eliminator) - goes between the venturi
    and the impeller housing

    It was very easy to do, just time consuming waiting the 1 hour for the wear rings to shrink in the freezer. After rebuilding the pumps and waiting 24 hrs. for the Loctite 518 to set I took a test run. WOT is about 100-200 RPM less than stock but 54-55 mph. The hole shot and midrange are greatly improved. I get to 30 mph instantly (appears to be 2-3 secs) as soon as I give full throttle from a dead stop. I'm very happy with my purchase/upgrade.
    Last edited by spd5535; 01-29-2008 at 11:41 AM.

  9. #9
    SPD5535, what altitude are you running at and I assume speed is gps.


    I am still thinking that the shaft rope guard on the 07's is causing my lower top speeds. Anyone have any other ideas??

  10. #10
    I can only say that my opinion based on a challenger twin 800`s:
    yes, I think the shaft protectors are creating some disturbance with aftermarket props. Sometimes they cavatate when pushed full throttle, sometimes not, right now lenny is changing the seals on the weed system, everything has been replaced with new. sgafts, all seals, one pump new, one pump rebuilt with all new inards. after working on this boat with all new components wear rings incl., the only thing that`s not SD is the skat props I believe they are 17\22 (small 140mm) so if the weed system seals don`t fix the cavatation, then the only other thing to do is re-install the stock props...

    IMHO, I think the stock props do a good all around job from idle to WOT. I think`s it is also a compromise on what you want to give up, speed or bottom end for towing a tube. just my 2 cents worth...PR...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 08-14-2015, 04:06 PM
  2. What impellers are these?
    By rlharrison60 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-27-2008, 11:30 PM
  3. What impeller are you using?
    By xlint89 in forum Polaris PWC Performance
    Replies: 35
    Last Post: 10-28-2007, 11:23 AM
  4. what size are the threads on the pump impeller?
    By Green Hulk in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-03-2007, 11:26 PM
  5. What do you recommend?
    By kenshin89 in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-02-2005, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •