Results 1 to 3 of 3
  1. #1

    Unhappy electrical nite mare

    I just purched a 96 slt 780 and it charges 22 volts at an idle, idles good but wont rev up, runs terrible off idle. it also has the bilge pump running all the time. and the mfd screen blew, commpression is good. and good spark, and new fuel. carbs are good new kits put in them. any suggestions would help, thanks


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Replace the voltage regulator and see how many problems get solved.

    4060115REGULATOR/RECT/CUT-OFF Substituted by 4060171

    Oh and WELCOME to the Green Hulk Forums!!!

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the hulk. Do what he said ^^^^ and see if the fuse for the MFD is blown. (most likely) It's inside the black elec. box.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. removing pins from electrical plugs?
    By Lurker in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 02-10-2006, 01:54 PM
  2. Electrical supercharger ?
    By Sammy-swed in forum 4-Tec Performance
    Replies: 4
    Last Post: 12-05-2005, 04:36 PM
  3. So what are you guys up to on this Wednesday nite??
    By two2curupt in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 11-23-2005, 10:35 PM
  4. So what are you guys up to on this Tuesday nite??
    By two2curupt in forum Sea Doo Open Discussion
    Replies: 44
    Last Post: 11-23-2005, 08:17 PM
  5. Electrical Problems
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-31-2005, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •