Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Supercharger Spline Stripped

    I had a plug fall off the back of the ignition module which the dealer located and replaced. During testing to make sure the issue was resolved he found the engine was still not running correctly.

    The problem was the spline on the Supercharger pully has stripped! Kawasaki has asked the dealer to send them the SC because they say they have not seen this problem before. They are replacing it under warranty.

    Unfortunatly I don't have any pics, because this was just info the dealer gave me over the phone.

    Anyone else seen this?

    Ski is standard except for Wedge and has about 10 hours.


  2. #2

    Join Date
    Oct 2006
    Location
    melrose ma
    Posts
    411

    sc......

    my s.c. seazed after 18 minuts of use......took two weeks to replace.....now there are other issues....

  3. #3
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Quote Originally Posted by petros the plumber View Post
    my s.c. seazed after 18 minuts of use......took two weeks to replace.....now there are other issues....
    What was the findings on why it seized?

  4. #4

    Join Date
    Oct 2006
    Location
    melrose ma
    Posts
    411

    reply....

    never found out y.....we believe the frount bearing sezed.....but it just got turned into another log #.........

  5. #5
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    did you do the oil level mod?

  6. #6

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451

    Talking

    Quote Originally Posted by Region8Ultra250X View Post
    did you do the oil level mod?
    The oil level mod as you call it, has nothing to do with the S/C.

  7. #7
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    Quote Originally Posted by Big Red Monster View Post
    The oil level mod as you call it, has nothing to do with the S/C.

    my bad. i thought maybe the supercharger was lubricated with oil from the engine and possibly the reduced engine oil level enough that the supercharger was not getting enough oil....

    sorry my mistake

  8. #8
    Got some more feedback from the dealer. Looks like the retaining bolt for the SC pully was never installed.

    While I would have rather not had any problems, I am very happy with my new dealer (if you are in Queensland feel free to PM me for details) and Kawasaki in the way they fixed the issue. Can't ask for more.

    Can't wait to go for a blast on Sunday!

  9. #9

    Join Date
    May 2007
    Location
    Savannah, GA
    Posts
    406
    Glad it's playing out in a "simple" fashion, and that it's not a battle of the warranty.

    Let us know how it turns out!

  10. #10

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451

    Wink

    Quote Originally Posted by Region8Ultra250X View Post
    my bad. i thought maybe the supercharger was lubricated with oil from the engine and possibly the reduced engine oil level enough that the supercharger was not getting enough oil....

    sorry my mistake


    Not to worry. That`s why we have this site.
    The S/C oil is a separate reservoir. That`s a good thing IMHO.
    My Sea-Doo S/C took a dump inside my motor. That`s why I ride the new 250X

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supercharger bolt stripped
    By rmk82nd in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-24-2015, 05:37 PM
  2. Impeller and Shaft Separated, Splines stripped.
    By majundecid in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-08-2011, 08:59 PM
  3. supercharge screw stripped
    By stevorxp007 in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-30-2010, 08:52 AM
  4. Need major help! Stripped bolt head on Supercharger bolt!?
    By pachi33 in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-09-2009, 09:45 PM
  5. stripped bolt on supercharger?????
    By bruno65 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-08-2007, 10:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •