Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2007
    Location
    N.E. Colorado
    Posts
    18

    Another ?fuel? question

    Good morning everyone,
    I have a 96 sl650std. The thing has been running pretty good till the past 2 weekends. I have been having to pull the choke to start more and more. Then it has started dieing on the water, but if I pulled the choke while it was dieing, it would pick back up. Then I thought I got it figured out, but when I made a left turn it would bog down and want to die. The last time after fuming about that, it did the run/die thing again. We took fuel pump off and made sure it was clean, checked the fuel vac line, checked the lines in the tank. When I take the intake cover off and look down into the carbs and try to start it, I don't see any fuel going in (thus the need to choke). I have been reading other posts this morning and I went and took off the fuel selector and made sure that was clean. I still have a single outlet fuel pump (didn't see a need (yet) to get the triple outlet since it has been running well). I am at a loss of what to do next. Any advise would be greatly appreciated.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Clean the carbs and check the screen in the carbs.

  3. #3

    Join Date
    Mar 2007
    Location
    N.E. Colorado
    Posts
    18
    What is the best way to clean the carbs? I have tried to download/view the diagrams from here but my adobe is not working well that is why I posted.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Disassemble and check the screens and jets for blockages. I can convert the pdf to word if you need it.

  5. #5

    Join Date
    Mar 2007
    Location
    N.E. Colorado
    Posts
    18
    If you think converting it to word would work better, GREAT! Would you like my email?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another EFI question, arrgggghhh
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-01-2006, 10:13 PM
  2. Another Head Question (or 3!)
    By washingtonrider in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-08-2006, 02:24 PM
  3. Another trailer question
    By Piney in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-17-2006, 06:15 PM
  4. Yet another EFI question...
    By Super in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 06-06-2006, 11:19 AM
  5. another fogging question?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 11-10-2005, 05:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •