Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    2007 SeaDoo Rxt Sosa62's Avatar
    Join Date
    May 2007
    Location
    Miami Fl
    Posts
    219
    +1
    1

    60.9 Mph on my RXT BLAHHH!! Can it be my Wear ring?

    Hows it going everyone well today I went out for a little ride cause the waters on the beach were super smooth. I figured Id give it some gas and see what it would do. I got a Garmin 76s Gps mounted in the glove box so its not a dream o meter.. I pulled out 60.9mph.. My friend who is my Mechanic ( certified mechanic LMAO) says its my Wear ring, Memorial day weekend I caught a large rock and it made my ring wear down quite it bit. Think hes right? he said with a new wear ring i should be back to 64-65mph??

    Fuel tank was @ 3/4 and I weight 240 riding solo with no gear.
    I really hope it was the wear ring.

    My soon to be mods are gonna include a Intake grate, Pump Wedge, and the Opas block offs. Think this will add 2-3mph???

    This monday im gonna be completing my 10hr service, the ski is at 12hrs now. Also gonna check the supercharger for faulty washers.
    I keep hearing that they are ceramic from everyone here but from my mechanic and the dealers mechanic assure me they are metal.. I guess the only way to find out is to pull it out huh?
    Thanks in advance for any help you may offer.
    Adrian


  2. #2
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    You've got to monitor engine rpm's- do you know what they were?

    Your washers are ceramic. Your mechanics are not knowledgeable on this matter... that's bad.

  3. #3
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Wear ring. The RXT is not going to run 60 without the sc. Need rpm's though, could be major slippage. Tell your mechanic and the dealers mechanic to STFU since it's obvious they are without a clue.

  4. #4
    2007 SeaDoo Rxt Sosa62's Avatar
    Join Date
    May 2007
    Location
    Miami Fl
    Posts
    219
    +1
    1
    Thanks, I'm gonna smack some sense into my mechanic when I see him next time. How can I tell if the supercharger is slipping rpms were running fine at all speeds I didn't pay attention to top speed rpms though going out today to check.
    How hard is it to replace a wear ring? I think I'm gonna shoot for a SS one.
    Thanks
    Adrian

  5. #5
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063
    take the SC out replace the ceramics with metal and retorque......i just replaced my wear ring, it took about 10 min to pull the pump and an hour waiting time to freeze everything.....look in the faq sections its realllll simple

  6. #6
    Well if that wear ring got chewed up that bad then you should really be cavatating out of the hole...is it? I'd be surprised if the wear ring itself was causing a loss of 5mph unless it's just shredded. Most I've heard of a bad wear ring scrubbing was 2~3mph.

  7. #7
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,548
    +1
    4,766
    Ya might try a set of fresh plugs...

  8. #8
    Quote Originally Posted by YoYamma View Post
    Ya might try a set of fresh plugs...
    I don't think plugs would cause a loss in speed. I think it's a "they're either firing or they're not" kinda thing. If a plug or plugs is the problem then he I don't think he would have all 3 cylinders, and in that case I don't think he would even see 60mph.

    But I'm not sure. Has anyone ever recovered lost speed from simply installing a new set of plugs?


    My guess is that he's low on RPM and that his clutch is slipping too early. Can you maintain your top speed or is the ski surging at wide open throttle? Also, check your oil level. Make sure it's halfway between the two bends and not over the top bend. Check your impeller cone (not pump cone) and see if it has slid up the driveshaft at all. If it has then it will rob you of RPM and speed. I doubt this has happened though. Look up through your intake grate to check.

    Finally, at only 12 hours I think the ski is still loosening up a bit. I have an RXP (same engine though) and didn't start seeing my best and most consistent top speeds until after the first 20 hours. However, you are not going to see a 5mph gain from now until the 20 hour mark. Maybe 1mph.

    Like NCHeel said, we definately need to know your RPM. Without knowing RPM finding a problem can be difficult.
    Last edited by RXP-REX; 06-29-2007 at 07:25 PM.

  9. #9
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    The gauge should always display rpm's when your riding. That is your best diagnostic tool. The speedo sucks and none of the other readouts are relevant. In other words watch your rpm's and you will know sooner than any other way when you have a problem.

  10. #10
    2007 SeaDoo Rxt Sosa62's Avatar
    Join Date
    May 2007
    Location
    Miami Fl
    Posts
    219
    +1
    1
    Thanks for the info tommorow I'm gonna check it out, ran into complications today. When I hit top speed there was no slipping felt strong the whole way. Out of the hole is where I feel a difference from the first couple of rides. I will report back tommorow with my rpms. I'm ordering a new wear ring tommorow and the supercharger washers just to be certain hopefully take advantage of everything at once while I'm in for the 10 hr service.
    Thanks,
    Adrian

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Over 70 mph on my 250x this morning :)
    By DTHNZ in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 04-17-2015, 03:56 AM
  2. New best MPH on 2012 RXT!
    By boostedgta in forum 4-Tec Performance
    Replies: 24
    Last Post: 08-22-2014, 07:20 AM
  3. Kevin Shaw goes 90 mph on my Turbo VXR
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 69
    Last Post: 12-16-2013, 10:28 AM
  4. Hit a log at 60 mph on my 09 rxpx, suggestions?
    By 98gsxl951 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 07-06-2011, 11:58 AM
  5. 84.8 mph on my big bore GPR!
    By Pistonwash in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2008, 09:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •