Results 1 to 5 of 5
  1. #1
    PWCless for now Majumba's Avatar
    Join Date
    Aug 2006
    Location
    Eagan, MN
    Posts
    140

    Got the SLX back together...

    Is it possible to get the cable connected to the starter with everything (and I mean everything) already assembled? Apparently I missed that step. I have already installed the engine twice since I forgot that the exhaust won't go in after the engine is mounted with the manifold on. Oops. Otherwise everything looks good, haven't attempted a start , well because the starter isn't attached. Hooked up the battery and got the MFD to light up. Time to drag it up north, add fluids, connect the starter, fire her up and start carb tuning. Wish me luck.


  2. #2
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Yes its very possible. I hooked up my starter cable last becuase i had for gotten to. If you have skinny arms like me it should be no problem.

  3. #3
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    HA HA HA, I don't feel so bad. I did the same thing on my first SBT boat anchor on my SLX. You'll never make that mistake again. I took the exhaust pipe back off, I think I took the manifold back off too. I can't remember for sure.

  4. #4
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    Quote Originally Posted by xplayer2885 View Post
    Yes its very possible. I hooked up my starter cable last becuase i had for gotten to. If you have skinny arms like me it should be no problem.
    You must be thin as paper unlike me.

  5. #5
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Quote Originally Posted by Polaris_Nut#1 View Post
    You must be thin as paper unlike me.
    Im a runner thats why lmao

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got the impeller back from Impros
    By 97GPSLEEPER in forum Yamaha Old School Skis
    Replies: 34
    Last Post: 10-12-2009, 04:13 PM
  2. Finally putting the RXP back together!
    By INDY27 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-03-2009, 12:14 PM
  3. Got my GPR back together and found bad news
    By spraydrice in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 06-01-2009, 03:53 PM
  4. Replies: 37
    Last Post: 07-29-2007, 09:46 AM
  5. Got the ski back today....!!!
    By GeoRXT in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-24-2006, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •